summaryrefslogtreecommitdiff
path: root/sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild')
-rw-r--r--sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild b/sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild
new file mode 100644
index 000000000000..175d1c7aec29
--- /dev/null
+++ b/sci-libs/scikit-image/scikit-image-0.19.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Image processing routines for SciPy"
+HOMEPAGE="https://scikit-image.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/imageio[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pywavelets[${PYTHON_USEDEP}]
+ dev-python/scipy[sparse(+),${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+DOCS=( CONTRIBUTORS.txt RELEASE.txt )
+
+distutils_enable_tests pytest
+# There is a programmable error in your configuration file:
+#distutils_enable_sphinx doc/source dev-python/numpydoc dev-python/myst_parser
+
+python_test() {
+ # This needs to be run in the install dir
+ cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/skimage" || die
+ distutils-r1_python_test
+}
+
+pkg_postinst() {
+ optfeature "FITS io capability" dev-python/astropy
+ optfeature "GTK" dev-python/pygtk
+ optfeature "Parallel computation" dev-python/dask
+ optfeature "io plugin providing most standard formats" dev-python/imread
+ # not in portage yet
+ #optfeature "io plugin providing a wide variety of formats, including specialized formats using in medical imaging." dev-python/simpleitk
+}