summaryrefslogtreecommitdiff
path: root/sci-libs/scalapack/scalapack-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sci-libs/scalapack/scalapack-2.1.0.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sci-libs/scalapack/scalapack-2.1.0.ebuild')
-rw-r--r--sci-libs/scalapack/scalapack-2.1.0.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/sci-libs/scalapack/scalapack-2.1.0.ebuild b/sci-libs/scalapack/scalapack-2.1.0.ebuild
index a1979a20ad64..d755a5b1ea9d 100644
--- a/sci-libs/scalapack/scalapack-2.1.0.ebuild
+++ b/sci-libs/scalapack/scalapack-2.1.0.ebuild
@@ -1,13 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils fortran-2 toolchain-funcs
+inherit cmake fortran-2 toolchain-funcs
+
+GCC10_PATCH_HASH="bc6cad585362aa58e05186bb85d4b619080c45a9"
DESCRIPTION="Subset of LAPACK routines redesigned for heterogenous (MPI) computing"
HOMEPAGE="https://www.netlib.org/scalapack/"
-SRC_URI="https://www.netlib.org/scalapack/${P}.tgz"
+SRC_URI="
+ https://www.netlib.org/scalapack/${P}.tgz
+ https://github.com/Reference-ScaLAPACK/scalapack/commit/${GCC10_PATCH_HASH}.patch -> ${P}-gcc10.patch
+ "
LICENSE="BSD"
SLOT="0"
@@ -15,17 +20,16 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
virtual/lapack
virtual/mpi"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
-PATCHES=(
-)
+PATCHES=( "${DISTDIR}/${P}-gcc10.patch" )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use static-libs; then
mkdir "${WORKDIR}/${PN}_static" || die
@@ -43,7 +47,7 @@ src_configure() {
-DBUILD_TESTING=$(usex test)
$@
)
- cmake-utils_src_configure
+ cmake_src_configure
}
scalapack_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
@@ -53,15 +57,15 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake_src_compile
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake_src_install
insinto /usr/include/blacs
doins BLACS/SRC/*.h