summaryrefslogtreecommitdiff
path: root/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild')
-rw-r--r--sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
index 055c225edf1d..7f57da918ba9 100644
--- a/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
+++ b/sci-libs/rosetta-fragments/rosetta-fragments-3.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic prefix toolchain-funcs
@@ -17,22 +17,25 @@ IUSE=""
DEPEND=""
RDEPEND="
sci-biology/ncbi-tools
- || ( sci-biology/update-blastdb sci-biology/ncbi-tools++ )
+ sci-biology/update-blastdb
sci-biology/psipred"
RESTRICT="fetch"
S="${WORKDIR}"/${PN/-/_}
+PATCHES=(
+ "${FILESDIR}"/${P}-nnmake.patch
+ "${FILESDIR}"/${P}-chemshift.patch
+)
+
pkg_nofetch() {
einfo "Go to ${HOMEPAGE} and get ${PN}.tgz and rename it to ${A}"
einfo "which must be placed in ${DISTDIR}"
}
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-nnmake.patch \
- "${FILESDIR}"/${P}-chemshift.patch
+ default
tc-export F77
eprefixify nnmake/*.pl
}
@@ -52,5 +55,8 @@ src_install() {
insinto /usr/share/${PN}
doins -r *_database
- dodoc fragments.README nnmake/{nnmake.README,vall/*.pl} chemshift/chemshift.README
+ dodoc \
+ fragments.README \
+ nnmake/{nnmake.README,vall/*.pl} \
+ chemshift/chemshift.README
}