summaryrefslogtreecommitdiff
path: root/sci-libs/rocSPARSE
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /sci-libs/rocSPARSE
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'sci-libs/rocSPARSE')
-rw-r--r--sci-libs/rocSPARSE/Manifest3
-rw-r--r--sci-libs/rocSPARSE/metadata.xml19
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild51
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/rocSPARSE/Manifest b/sci-libs/rocSPARSE/Manifest
new file mode 100644
index 000000000000..0450ae034681
--- /dev/null
+++ b/sci-libs/rocSPARSE/Manifest
@@ -0,0 +1,3 @@
+DIST rocSPARSE-4.0.0.tar.gz 587761 BLAKE2B 25f9f0183c06b574505fe6e9011b32ea4fbe48c0a1883b8991baf45b8a2238312f352e614c0069531c986e548453b6e7b7a77f883dffea82ed41df488964b55d SHA512 4a4acf24a789ea58b53a8d06ea528a6aed8eabac21a7a3cd73011e9b31d03dceb488cc72f29c5513205f2b538d24e9dbaccda1a932bcc466cd04a65606a77b3b
+EBUILD rocSPARSE-4.0.0-r1.ebuild 1166 BLAKE2B fc45fdaaf8d5f20afcc0d477eac01d30100a3ac3355ddae786ee934f46ef55b4f6ac3b284875fc905f75452cbfbb655ad4cfb9f916905e1a6091e8b97a14f141 SHA512 221e3aea6c45e7d7a6edc3b96db32ed9d2deb040f1f4cafa9cbb139a146aa7500d4619e6e8db39683fed9c0bc34053dc8ede22525340457c1774f6ea90297a98
+MISC metadata.xml 588 BLAKE2B 31fa8e3f62668dcfceb07268b802f4fb7d4947e29922a13e21fc216e8e8d0a80c204e015bc892ff2ecaa974e4fb2a94e07229d43852b64979dc664a577ce5b41 SHA512 3685dc06581c36139790eb244f0fd6474cdba6e8949b41db4294dd4870d49a57fcea13d0ffb8fe89da47f81e4da161b236cf16e78de67a8ceba72a42f9da52a5
diff --git a/sci-libs/rocSPARSE/metadata.xml b/sci-libs/rocSPARSE/metadata.xml
new file mode 100644
index 000000000000..73cc3d7be191
--- /dev/null
+++ b/sci-libs/rocSPARSE/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/rocSPARSE</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..14e2518eb4a7
--- /dev/null
+++ b/sci-libs/rocSPARSE/rocSPARSE-4.0.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Basic Linear Algebra Subroutines for sparse computation"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocSPARSE"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-${PV}.tar.gz -> rocSPARSE-${PV}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="=dev-util/hip-$(ver_cut 1-2)*
+ =sci-libs/rocPRIM-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/rocSPARSE-rocm-${PV}"
+
+rocSPARSE_V="0.1"
+
+BUILD_DIR="${S}/build/release"
+
+src_prepare() {
+ sed -e "s/PREFIX rocsparse//" \
+ -e "/<INSTALL_INTERFACE/s,include,include/rocsparse," \
+ -e "/rocm_install_symlink_subdir(rocsparse)/d" \
+ -e "s:rocsparse/include:include/rocsparse:" \
+ -i "${S}/library/CMakeLists.txt" || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device to omit a sandbox violation
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_CLIENTS_SAMPLES=OFF
+ -DCMAKE_INSTALL_INCLUDEDIR="include/rocsparse"
+ )
+
+ cmake_src_configure
+}