summaryrefslogtreecommitdiff
path: root/sci-libs/rocRAND
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /sci-libs/rocRAND
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'sci-libs/rocRAND')
-rw-r--r--sci-libs/rocRAND/Manifest3
-rw-r--r--sci-libs/rocRAND/metadata.xml19
-rw-r--r--sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild46
3 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/rocRAND/Manifest b/sci-libs/rocRAND/Manifest
new file mode 100644
index 000000000000..cc5da9013360
--- /dev/null
+++ b/sci-libs/rocRAND/Manifest
@@ -0,0 +1,3 @@
+DIST rocRAND-4.0.0.tar.gz 3105585 BLAKE2B 0466d88c286290a9cd179fac61209051f7db5323457ccad9c5f0b579439662e1fe2b8951f85101c7c31bd058bc1448e839a19dc9a3a2d4ca42eb4e0b2baf4eb4 SHA512 c02bc32a9cf7660739ecf7ef99262fb14efa2c76afb3476105eedc4264dec987351ebd461c13c9e0aef9e640b42960b2a63295479664b83924cf0d5c34a157e8
+EBUILD rocRAND-4.0.0-r1.ebuild 1063 BLAKE2B 69823e3904b62ed811a7ea68c28b95c09e1059134e17fd62f006352e5870d2e3e9e111fbf8a1647cba517135ac46dcb829cabd98c91344bbfc1e38d7b996420a SHA512 06b4732ae433bc0996bd07fda884c7a302a4f33f92bde4b0c73eb684c8d793c3c9a0252e9961874e0fb4ab456ef584da7c47a98651fb704adf72f02e202b8c63
+MISC metadata.xml 586 BLAKE2B 72eee2fee63235c0e464a1aae761f0e862e2d7f6496d0530ab114435003188ed67cb3f0499afe5d11f2cc64019b09e2b2d8605a5a7a0d87d2477e858e3f284c8 SHA512 6dcc2e40f716b763586801119126d8e141f57be9900987733c858e1045a02833db80d8d9a538e96a47114b8f1d8404a2af17cd731b9ec7537efac88f2fa4a5ff
diff --git a/sci-libs/rocRAND/metadata.xml b/sci-libs/rocRAND/metadata.xml
new file mode 100644
index 000000000000..77cd8b248d11
--- /dev/null
+++ b/sci-libs/rocRAND/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/rocRAND</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild b/sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..1a112d2a73d1
--- /dev/null
+++ b/sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Generate pseudo-random and quasi-random numbers"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocRAND/archive/rocm-${PV}.tar.gz -> rocRAND-${PV}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="=dev-util/hip-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}
+ =dev-util/rocm-cmake-$(ver_cut 1-2)*"
+
+S="${WORKDIR}/rocRAND-rocm-${PV}"
+
+src_prepare() {
+ sed -r -e "s:(hip|roc)rand/lib:\${CMAKE_INSTALL_LIBDIR}:" \
+ -e "s:(hip|roc)rand/include:include/\1rand:" \
+ -e "/INSTALL_RPATH/d" -i library/CMakeLists.txt || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_TEST=OFF
+ )
+
+ cmake_src_configure
+ # do not rerun cmake and the build process in src_install
+ sed '/RERUN/,+1d' -i "${BUILD_DIR}"/build.ninja || die
+}