summaryrefslogtreecommitdiff
path: root/sci-libs/rocRAND
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /sci-libs/rocRAND
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'sci-libs/rocRAND')
-rw-r--r--sci-libs/rocRAND/Manifest4
-rw-r--r--sci-libs/rocRAND/metadata.xml3
-rw-r--r--sci-libs/rocRAND/rocRAND-4.3.0.ebuild72
3 files changed, 78 insertions, 1 deletions
diff --git a/sci-libs/rocRAND/Manifest b/sci-libs/rocRAND/Manifest
index 87f2d912da12..0f49fb480678 100644
--- a/sci-libs/rocRAND/Manifest
+++ b/sci-libs/rocRAND/Manifest
@@ -1,3 +1,5 @@
DIST rocRAND-4.0.0.tar.gz 3105585 BLAKE2B 0466d88c286290a9cd179fac61209051f7db5323457ccad9c5f0b579439662e1fe2b8951f85101c7c31bd058bc1448e839a19dc9a3a2d4ca42eb4e0b2baf4eb4 SHA512 c02bc32a9cf7660739ecf7ef99262fb14efa2c76afb3476105eedc4264dec987351ebd461c13c9e0aef9e640b42960b2a63295479664b83924cf0d5c34a157e8
+DIST rocRAND-4.3.0.tar.gz 3107367 BLAKE2B 23cfac271c1cd4e4edcfd315aa775d4d62e6a50ffa3b9a3372d4ae427a02def52486e88b3f4f89daaa539f2653cf76c8d44afec70d8d916268bc9f27534bda4c SHA512 3eefeb55014a8ee681e1cee73e0e092bd29a81767e772e712f8f871e94380a772a433e93a59276b0cd5a364fc4e482186771809d67ebdab24b2e3020173f5e18
EBUILD rocRAND-4.0.0-r1.ebuild 1063 BLAKE2B 69823e3904b62ed811a7ea68c28b95c09e1059134e17fd62f006352e5870d2e3e9e111fbf8a1647cba517135ac46dcb829cabd98c91344bbfc1e38d7b996420a SHA512 06b4732ae433bc0996bd07fda884c7a302a4f33f92bde4b0c73eb684c8d793c3c9a0252e9961874e0fb4ab456ef584da7c47a98651fb704adf72f02e202b8c63
-MISC metadata.xml 601 BLAKE2B 3ffcac5814fe9bb976bee3669a9956e58a923a9055b11dddddff760b66220ad654a7f56305641e4d35c6635f45cd71d5c75c72f72d03293c3c73c84b5154c337 SHA512 5188fcf9add9b0640200e2042b51ed100673abc751557375a13eb438633b96888139b6130ca67364d1008fc93a7f15cc071071b9e309428544a1573f7c2fb5b7
+EBUILD rocRAND-4.3.0.ebuild 1725 BLAKE2B a4f72473430dc7b9f52421ad974aa95f2fba68665536da5a60b976896d98ca0d0e88623c7569f75531f08315b7e57951f6d715b3044db4b07020cc974152ae76 SHA512 60bc0b7e0d19d8c929c9f2874d4ad2200361d48e4acfa53d68969c7752eb0116df81a5fb4cc2a5ae10923ee23757874e0d6a8d86576006c7565d5199780f9486
+MISC metadata.xml 698 BLAKE2B fd85075e1414d7756cb16ed17f79cfc8302db5319df3a0862d7ce9006277c33a392e1a37aa7f2b2bcb80fbae4589240dd43751eebdeb5688a90a868299c3ecad SHA512 645a284a2c3b0f95df57110a04d5f131f28e3d673ba12eb5b3f3d5e7ee30e3099a022187b86ed458d5b4d6bed1451bd3dfe620debe0e8c480aee35f57bc878eb
diff --git a/sci-libs/rocRAND/metadata.xml b/sci-libs/rocRAND/metadata.xml
index d9a40bdc1ec3..dfea5b6e3584 100644
--- a/sci-libs/rocRAND/metadata.xml
+++ b/sci-libs/rocRAND/metadata.xml
@@ -16,4 +16,7 @@
<upstream>
<remote-id type="github">ROCmSoftwarePlatform/rocRAND</remote-id>
</upstream>
+ <use>
+ <flag name="benchmark">Build and install benchmark programs.</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/rocRAND/rocRAND-4.3.0.ebuild b/sci-libs/rocRAND/rocRAND-4.3.0.ebuild
new file mode 100644
index 000000000000..926f784a0249
--- /dev/null
+++ b/sci-libs/rocRAND/rocRAND-4.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Generate pseudo-random and quasi-random numbers"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocRAND/archive/rocm-${PV}.tar.gz -> rocRAND-${PV}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="benchmark test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/hip:${SLOT}"
+DEPEND="${RDEPEND}
+>=dev-util/rocm-cmake-${PV}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rocRAND-rocm-${PV}"
+
+src_prepare() {
+ sed -r -e "s:(hip|roc)rand/lib:\${CMAKE_INSTALL_LIBDIR}:" \
+ -e "s:(hip|roc)rand/include:include/\1rand:" \
+ -e "/INSTALL_RPATH/d" -i library/CMakeLists.txt || die
+
+ # remove GIT dependency
+ sed -e "/find_package(Git/,+4d" -i cmake/Dependencies.cmake || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DBUILD_BENCHMARK=$(usex benchmark ON OFF)
+ -DCMAKE_SKIP_RPATH=TRUE
+ ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
+ -D__skip_rocmclang="ON" ## fix cmake-3.21 configuration issue caused by officialy support programming language "HIP"
+ )
+
+ cmake_src_configure
+ # do not rerun cmake and the build process in src_install
+ sed '/RERUN/,+1d' -i "${BUILD_DIR}"/build.ninja || die
+}
+
+src_test() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addwrite /dev/dri/
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ if use benchmark; then
+ cd "${BUILD_DIR}"/benchmark
+ dobin benchmark_rocrand_*
+ fi
+}