summaryrefslogtreecommitdiff
path: root/sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild')
-rw-r--r--sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild b/sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild
deleted file mode 100644
index 98f626fe7f9a..000000000000
--- a/sci-libs/rocPRIM/rocPRIM-4.3.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="HIP parallel primitives for developing performant GPU-accelerated code on ROCm"
-HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocPRIM"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/rocPRIM/archive/rocm-${PV}.tar.gz -> rocPRIM-${PV}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="benchmark test"
-
-RDEPEND="dev-util/hip:${SLOT}
- benchmark? ( dev-cpp/benchmark )"
-BDEPEND="dev-util/rocm-cmake:${SLOT}
- test? ( dev-cpp/gtest )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/rocPRIM-rocm-${PV}"
-
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- # "hcc" is depcreated, new platform ist "rocclr"
- sed -e "/HIP_PLATFORM STREQUAL/s,hcc,rocclr," -i cmake/VerifyCompiler.cmake || die
-
- # Install according to FHS
- sed -e "/PREFIX rocprim/d" \
- -e "/INSTALL_INTERFACE/s,rocprim/include,include/rocprim," \
- -e "/DESTINATION/s,rocprim/include,include," \
- -e "/rocm_install_symlink_subdir(rocprim)/d" \
- -i rocprim/CMakeLists.txt || die
-
- # disable downloading googletest and googlebenchmark
- sed -r -e '/Downloading/{:a;N;/\n *\)$/!ba; d}' -i cmake/Dependencies.cmake || die
-
- # remove GIT dependency
- sed -r -e '/find_package\(Git/{:a;N;/\nendif/!ba; d}' -i cmake/Dependencies.cmake || die
-
- # install benchmark files
- if use benchmark; then
- sed -e "/get_filename_component/s,\${BENCHMARK_SOURCE},${PN}_\${BENCHMARK_SOURCE}," \
- -e "/add_executable/a\ install(TARGETS \${BENCHMARK_TARGET})" -i benchmark/CMakeLists.txt || die
- fi
-
- eapply_user
- cmake_src_prepare
-}
-
-src_configure() {
- # Grant access to the device
- addwrite /dev/kfd
- addpredict /dev/dri/
-
- # Compiler to use
- export CXX=hipcc
-
- local mycmakeargs=(
- -DBUILD_TEST=$(usex test ON OFF)
- -DBUILD_BENCHMARK=$(usex benchmark ON OFF)
- ${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
- -D__skip_rocmclang="ON" ## fix cmake-3.21 configuration issue caused by officialy support programming language "HIP"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # Grant access to the device
- addwrite /dev/kfd
- addwrite /dev/dri/
- cmake_src_test
-}