summaryrefslogtreecommitdiff
path: root/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild')
-rw-r--r--sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild b/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
index 48945fe72456..3b4067eb964a 100644
--- a/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
+++ b/sci-libs/rocBLAS/rocBLAS-4.3.0.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake prefix python-any-r1
+inherit cmake multiprocessing prefix python-any-r1
DESCRIPTION="AMD's library for BLAS on ROCm"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocBLAS"
SRC_URI="https://github.com/ROCmSoftwarePlatform/rocBLAS/archive/rocm-${PV}.tar.gz -> rocm-${P}.tar.gz
https://github.com/ROCmSoftwarePlatform/Tensile/archive/rocm-${PV}.tar.gz -> rocm-Tensile-${PV}.tar.gz"
-LICENSE="MIT"
+LICENSE="BSD"
KEYWORDS="~amd64"
IUSE="benchmark test"
SLOT="0/$(ver_cut 1-2)"
@@ -46,7 +46,8 @@ S="${WORKDIR}"/${PN}-rocm-${PV}
PATCHES=("${FILESDIR}"/${PN}-4.3.0-fix-glibc-2.32-and-above.patch
"${FILESDIR}"/${PN}-4.3.0-change-default-Tensile-library-dir.patch
- "${FILESDIR}"/${PN}-4.3.0-link-system-blas.patch )
+ "${FILESDIR}"/${PN}-4.3.0-link-system-blas.patch
+ "${FILESDIR}"/${PN}-4.3.0-remove-problematic-test-suites.patch )
src_prepare() {
eapply_user
@@ -54,6 +55,7 @@ src_prepare() {
pushd "${WORKDIR}"/Tensile-rocm-${PV} || die
eapply "${FILESDIR}/Tensile-${PV}-hsaco-compile-specified-arch.patch" # backported from upstream, should remove after 4.3.0
eapply "${FILESDIR}/Tensile-4.3.0-output-commands.patch"
+ sed -e "/Number of parallel jobs to launch/s:default=-1:default=$(makeopts_jobs):" -i Tensile/TensileCreateLibrary.py || die
popd || die
# Fit for Gentoo FHS rule
@@ -97,7 +99,6 @@ src_configure() {
-DBUILD_CLIENTS_TESTS=$(usex test ON OFF)
-DBUILD_CLIENTS_BENCHMARKS=$(usex benchmark ON OFF)
${AMDGPU_TARGETS+-DAMDGPU_TARGETS="${AMDGPU_TARGETS}"}
- -D__skip_rocmclang="ON" ## fix cmake-3.21 configuration issue caused by officialy support programming language "HIP"
)
CXX="hipcc" cmake_src_configure