summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-libs/pyshp
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest2
-rw-r--r--sci-libs/pyshp/pyshp-2.1.2.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
index e5552b5236ea..6069248d35e8 100644
--- a/sci-libs/pyshp/Manifest
+++ b/sci-libs/pyshp/Manifest
@@ -1,3 +1,5 @@
DIST pyshp-2.1.0.tar.gz 215360 BLAKE2B 2b32a3db242b90f801abdbc31f3c930bc40c3ad0606433d90f62c6b9af3c0459e8c8467d60aec1075368779e5a4fffa9e3985e1875d82edf732faf982359c605 SHA512 ab0c7832f7e480ec3cdbf94ec29f84b590486625bde3d5cf465e5dc6ddca02998b99510b6c14d5ba005816c5b091044badc1e68988fd971f9e18266096ad86cb
+DIST pyshp-2.1.2.tar.gz 217857 BLAKE2B f4c50e16987b13b7968fe37e4e7f20329b6871c879b837113aac281527f6a00d5d13e10f93e8ecd5896cf089d801d76cec5d93645a6919fbc48d96d4318bb767 SHA512 54fadaa133d3fbf3b9a318be02dd21c2a35a3c58c15de8e6d0cffa6ca83eefe12603fe5930d3df63ad4c6a6d711336752f08923c6406168207ac291d05592582
EBUILD pyshp-2.1.0.ebuild 549 BLAKE2B 34a54b03e748fae8daad52154dce55d32be41d1638242c183210007015945eba8acb5ba6a09c8d274334543e4ee8c939f669079555b748f7e8e8afff38612914 SHA512 7dfcab869adfc8aca9c706c2e63f9b80baa4f61efa59f0c10299644a7fccc9c867dee781e4c52914b8eeca6961ccf6b85793fd2ca1210e369689a477086041c0
+EBUILD pyshp-2.1.2.ebuild 549 BLAKE2B 34a54b03e748fae8daad52154dce55d32be41d1638242c183210007015945eba8acb5ba6a09c8d274334543e4ee8c939f669079555b748f7e8e8afff38612914 SHA512 7dfcab869adfc8aca9c706c2e63f9b80baa4f61efa59f0c10299644a7fccc9c867dee781e4c52914b8eeca6961ccf6b85793fd2ca1210e369689a477086041c0
MISC metadata.xml 327 BLAKE2B 48f3a2409f354b39c05d8111f78f1bce40425f79db30c83d345f81a081d2098bdf42dfc49e47854ec788cf75841cb9427a5c2eb9b71dd139f3fbe398e1380346 SHA512 3b9fdbf92fc5ad41b8afe4b315bad42806062c974b37496875fcc861af525905cc8d4b81e0a4d20d3e9333ea38c57c7aae6764c64537ef9e27386a53168299b4
diff --git a/sci-libs/pyshp/pyshp-2.1.2.ebuild b/sci-libs/pyshp/pyshp-2.1.2.ebuild
new file mode 100644
index 000000000000..5499cd13c879
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" shapefile.py || die
+}