summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-02 20:24:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-02 20:24:39 +0000
commit7a13078cb414752df1133d1767cc29260dc60fda (patch)
tree9e90a6f188f34228806cf884fc9733e53912a371 /sci-libs/pyshp
parent7e76f9a8d4e868d30c8bf1781655cc25574c80f8 (diff)
gentoo auto-resync : 02:01:2023 - 20:24:39
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest2
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild7
2 files changed, 5 insertions, 4 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
index 518a8f3248ed..0da2a5a4dece 100644
--- a/sci-libs/pyshp/Manifest
+++ b/sci-libs/pyshp/Manifest
@@ -1,5 +1,5 @@
DIST pyshp-2.1.3.tar.gz 219626 BLAKE2B 2da94cb4b1514a504b9f961b58add973a73dea641ad5867b670860000decd29af72092079b5d16f516b99a59be83028f4698faa2cb013200e533bbe772746d48 SHA512 249302e784bb38860037242b70899faaf504ef626c37decca44dc0d7c4f9482737e3234c0002393d1ef9800778715fc2b9946f3e3f3ecf507921e9db218d0d33
DIST pyshp-2.3.1..gh.tar.gz 2213685 BLAKE2B ca5b87dec442508bc4a0612982984ba0fb91aa8acffddb6a448c43ccf42285305600a5e28e1fb781a3d94e8ce0624d027642fddcc5f2176dca3df095e59df170 SHA512 08844492b8d1d824c639844f7f314909d946bd4d3703a4f8d4cb64d400729671b42ff5b0f80aa68d9469f3939a3c7619ba13c9efdcba3b244ec01d7be3a371c5
EBUILD pyshp-2.1.3.ebuild 549 BLAKE2B a48d9defa84bed8d33e05da68c64daa98d2f4af0265e35d7ddecb7458d8104536b9c7f16070fb009d0aa72d244440ca13e1effec239efbcd9efce276df07abc5 SHA512 ff101b2859f9d70b3f4b06356820709f55d6451d3b7116a3ed17f3e0331d364a2c76f9e405ec078a39b09a829e50848b8ca4b602b5c1d54ef8a9ddc8a3f439b3
-EBUILD pyshp-2.3.1.ebuild 697 BLAKE2B 8ac219194cbb868665340e4f087e9d88a4939ce3ff10fb22b38679bc6014704f2ed47a369a8e8090fb287dde821927863cb00498b39e6ff2c508719272ce89a9 SHA512 716e6f063da3d13bff5e75ac5017d3e2ff34ae39f437abe17955472e84eb1ccf07cf2eebe794cf796e1506c40b40213facc025be02ff0888f3d99151c05e474a
+EBUILD pyshp-2.3.1.ebuild 744 BLAKE2B 1d455bfd51f242582fb23d65ed7a14d5b4c57ebd083e5e1432c7e87c635f21f9f6a1d776fdce13d1db0af09e699b48325de1bb06185ef9fff23af6fb7ce257c1 SHA512 b9102ce180168dea3b9790e57af68fbe424ea0847bdd7d43cb7924ed35e9d6787658a89f7125346955435d01c6c4d839199fa6b4ef3f98f879c5d55e14424d88
MISC metadata.xml 392 BLAKE2B d0502636f7a083b4eca21dd9c9cb2604d96ec91616c88566f42687e53be965090683984d3289ae332c94309e89b25f39a12b601467abec718365d53f423fe21d SHA512 b3914985e7b8857a7f0841d4e987746f64a571a83ed3a237621c048e073c1f5a77512c40011ee1808c3ffadff08c03adc53ffe767e8a5f35c628882df779b771
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
index af715dcb9263..dc041f721f8e 100644
--- a/sci-libs/pyshp/pyshp-2.3.1.ebuild
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{7..11} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
@@ -20,7 +20,8 @@ RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
epytest test_shapefile.py -m "not network" || die