summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
commit5e0a5ca921524f8859808527a57655eec16efa52 (patch)
tree7c58411b1e81478df4e20082a6adec2553c24c5c /sci-libs/pyshp
parent4c16e0a214824f15f09396e359db4f1f5c086fec (diff)
gentoo auto-resync : 18:07:2023 - 00:58:24
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest1
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
index 060b03054125..d24effab047d 100644
--- a/sci-libs/pyshp/Manifest
+++ b/sci-libs/pyshp/Manifest
@@ -1,3 +1,4 @@
DIST pyshp-2.3.1..gh.tar.gz 2213685 BLAKE2B ca5b87dec442508bc4a0612982984ba0fb91aa8acffddb6a448c43ccf42285305600a5e28e1fb781a3d94e8ce0624d027642fddcc5f2176dca3df095e59df170 SHA512 08844492b8d1d824c639844f7f314909d946bd4d3703a4f8d4cb64d400729671b42ff5b0f80aa68d9469f3939a3c7619ba13c9efdcba3b244ec01d7be3a371c5
+EBUILD pyshp-2.3.1-r1.ebuild 777 BLAKE2B 59870ff54c0a4a3b8ace5ca05ff0225fdbfb6d9cb1cacee8d3b7759a92099fb4dfd1fdc2a62bd7d53e47bfb481ba4f9df996ed99298ecbcecca0fd3292f91e6f SHA512 5f47eb6e8138c64c6b4ccac8288d01216c7180fdefd486a8c4be2e30327b21af8f56806f01baec58bc23668a3c13056c7d5549d8a9f3473224133a4f28b470cd
EBUILD pyshp-2.3.1.ebuild 744 BLAKE2B b4b76c57382af71032a53452a23935444612a1619a857ca66155ca7aa04b46bba20295a48f196fd2e4f444f46c08dd2030bc7ef7dd7789237073815e65d0da75 SHA512 2d4ed1891ac28ecb8a06c40c2b53e1270a63c6a694243b867660ca8c77af06ffb28e680f2b7c902c76b8e85d807bcb0afe7671faa8cc25441ef8d97b4bd9e6c1
MISC metadata.xml 392 BLAKE2B d0502636f7a083b4eca21dd9c9cb2604d96ec91616c88566f42687e53be965090683984d3289ae332c94309e89b25f39a12b601467abec718365d53f423fe21d SHA512 b3914985e7b8857a7f0841d4e987746f64a571a83ed3a237621c048e073c1f5a77512c40011ee1808c3ffadff08c03adc53ffe767e8a5f35c628882df779b771
diff --git a/sci-libs/pyshp/pyshp-2.3.1-r1.ebuild b/sci-libs/pyshp/pyshp-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..813c53e427ef
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}