summaryrefslogtreecommitdiff
path: root/sci-libs/profnet/profnet-1.0.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/profnet/profnet-1.0.22.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/profnet/profnet-1.0.22.ebuild')
-rw-r--r--sci-libs/profnet/profnet-1.0.22.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/profnet/profnet-1.0.22.ebuild b/sci-libs/profnet/profnet-1.0.22.ebuild
new file mode 100644
index 000000000000..df450e7e8d39
--- /dev/null
+++ b/sci-libs/profnet/profnet-1.0.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit fortran-2 toolchain-funcs
+
+DESCRIPTION="Neural network architecture for profacc"
+HOMEPAGE="https://rostlab.org/"
+SRC_URI="ftp://rostlab.org/profnet/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-libs/libunwind"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed \
+ -e '/$@/s:-o:$(LDFLAGS) -o:g' \
+ -i src-phd/Makefile || die
+}
+
+src_compile() {
+ emake \
+ F77=$(tc-getF77) \
+ FFLAGS="${FFLAGS}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ install
+}