summaryrefslogtreecommitdiff
path: root/sci-libs/pcl/pcl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sci-libs/pcl/pcl-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sci-libs/pcl/pcl-9999.ebuild')
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index 19c912a12d8c..340870c8b8e2 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -23,7 +23,7 @@ fi
HOMEPAGE="http://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
-SLOT="0/1.9"
+SLOT="0/1.11"
IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
RESTRICT="!test? ( test )"
@@ -49,9 +49,11 @@ RDEPEND="
"
DEPEND="${RDEPEND}
!!dev-cpp/metslib
+ test? ( >=dev-cpp/gtest-1.6.0 )
+"
+BDEPEND="
doc? ( app-doc/doxygen )
tutorials? ( dev-python/sphinx dev-python/sphinxcontrib-doxylink )
- test? ( >=dev-cpp/gtest-1.6.0 )
virtual/pkgconfig"
REQUIRED_USE="
@@ -72,9 +74,7 @@ src_configure() {
"-DWITH_VTK=$(usex vtk TRUE FALSE)"
"-DWITH_PCAP=$(usex pcap TRUE FALSE)"
"-DWITH_OPENNI=$(usex openni TRUE FALSE)"
- "-DBUILD_OPENNI=$(usex openni TRUE FALSE)"
"-DWITH_OPENNI2=$(usex openni2 TRUE FALSE)"
- "-DBUILD_OPENNI2=$(usex openni2 TRUE FALSE)"
"-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
"-DWITH_DOCS=$(usex doc TRUE FALSE)"
"-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"