summaryrefslogtreecommitdiff
path: root/sci-libs/pcl/pcl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
commit8fd9d385e5bc3c01115ec2ddcb2227607eb90861 (patch)
treeaba1e6ef6b95e94172c009394cd1fcbc383e7d6e /sci-libs/pcl/pcl-9999.ebuild
parent1ddcee0bd115d2f843f82061cb0d1741bf90151d (diff)
gentoo auto-resync : 05:01:2024 - 14:04:25
Diffstat (limited to 'sci-libs/pcl/pcl-9999.ebuild')
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index 9de81c659155..6247e7718047 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
SLOT="0/$(ver_cut 1-2)"
-IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 qt6 usb vtk cpu_flags_x86_sse test tutorials"
# tests need the gtest sources to be available at build time
RESTRICT="test"
@@ -37,6 +37,13 @@ RDEPEND="
dev-qt/qtcore:5
dev-qt/qtconcurrent:5
dev-qt/qtopengl:5
+ vtk? ( sci-libs/vtk[qt5] )
+ )
+ qt6? (
+ !qt5? (
+ dev-qt/qtbase:6[concurrent,gui,opengl]
+ vtk? ( sci-libs/vtk[-qt5,qt6] )
+ )
)
usb? ( virtual/libusb:1 )
vtk? ( >=sci-libs/vtk-5.6:=[imaging,rendering,views] )
@@ -87,7 +94,6 @@ src_configure() {
"-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
"-DWITH_PNG=$(usex png TRUE FALSE)"
"-DWITH_QHULL=$(usex qhull TRUE FALSE)"
- "-DWITH_QT=$(usex qt5 TRUE FALSE)"
"-DWITH_VTK=$(usex vtk TRUE FALSE)"
"-DWITH_PCAP=$(usex pcap TRUE FALSE)"
"-DWITH_OPENNI=$(usex openni TRUE FALSE)"
@@ -98,5 +104,13 @@ src_configure() {
"-DBUILD_global_tests=FALSE"
)
+ if use qt5; then
+ mycmakeargs+=( "-DWITH_QT=QT5" )
+ elif use qt6; then
+ mycmakeargs+=( "-DWITH_QT=QT6" )
+ else
+ mycmakeargs+=( "-DWITH_QT=NO" )
+ fi
+
cmake_src_configure
}