summaryrefslogtreecommitdiff
path: root/sci-libs/pcl/pcl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 14:00:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 14:00:21 +0000
commit84bfe2244c544bae8dcaffbaf4cfb80f59f88f64 (patch)
tree9ca9f927285afd8d1f973510490ab28847f36dd4 /sci-libs/pcl/pcl-9999.ebuild
parent5e0583283abb5e0f998830cea3f4f9785699b2ed (diff)
gentoo auto-resync : 04:01:2024 - 14:00:20
Diffstat (limited to 'sci-libs/pcl/pcl-9999.ebuild')
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index cc8d925c4502..9de81c659155 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -1,18 +1,13 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
-fi
+inherit cmake cuda
-inherit ${SCM} cmake cuda
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
else
KEYWORDS="~amd64 ~arm"
SRC_URI="https://github.com/PointCloudLibrary/pcl/archive/${P}.tar.gz"
@@ -22,7 +17,7 @@ fi
HOMEPAGE="https://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
-SLOT="0/1.12"
+SLOT="0/$(ver_cut 1-2)"
IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
# tests need the gtest sources to be available at build time
RESTRICT="test"