summaryrefslogtreecommitdiff
path: root/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-20 11:17:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-20 11:17:21 +0000
commit48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (patch)
treef88035a58c20099cf45a576fb53b0330a4754f14 /sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
parent0fb71e0215ed52863e462cccef73c01aff44d43d (diff)
gentoo resync : 20.12.2017
Diffstat (limited to 'sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild')
-rw-r--r--sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild b/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
new file mode 100644
index 000000000000..c94cad2a63ac
--- /dev/null
+++ b/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MYP=ParMGridGen-${PV}
+
+DESCRIPTION="Software for parallel (mpi) generating coarse grids"
+HOMEPAGE="http://www-users.cs.umn.edu/~moulitsa/software.html"
+SRC_URI="http://www-users.cs.umn.edu/~moulitsa/download/${MYP}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RESTRICT="mirror bindist"
+
+DEPEND="virtual/mpi"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MYP}
+
+pkg_setup(){
+ export CC=mpicc
+}
+
+PATCHES=(
+ "${FILESDIR}/${P}-autotools.patch"
+ "${FILESDIR}/${P}-as-needed.patch"
+ "${FILESDIR}/${P}-format-security.patch"
+ "${FILESDIR}/${P}-impl-fct.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc README Doc/*.pdf
+}