summaryrefslogtreecommitdiff
path: root/sci-libs/openblas/openblas-0.3.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/openblas/openblas-0.3.20.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/openblas/openblas-0.3.20.ebuild')
-rw-r--r--sci-libs/openblas/openblas-0.3.20.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-libs/openblas/openblas-0.3.20.ebuild b/sci-libs/openblas/openblas-0.3.20.ebuild
index 5d2349e6998f..01fd54d252c4 100644
--- a/sci-libs/openblas/openblas-0.3.20.ebuild
+++ b/sci-libs/openblas/openblas-0.3.20.ebuild
@@ -12,7 +12,7 @@ S="${WORKDIR}"/OpenBLAS-${PV}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="dynamic eselect-ldso index-64bit openmp pthread relapack test"
REQUIRED_USE="?? ( openmp pthread )"
RESTRICT="!test? ( test )"
@@ -28,9 +28,12 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-0.3.12-shared-blas-lapack.patch"
"${FILESDIR}/${PN}-0.3.20-fix-riscv.patch"
+ "${FILESDIR}/${PN}-0.3.20-fix-loong.patch"
)
pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
elog "This software has a massive number of options that"
elog "are configurable and it is *impossible* for all of"
elog "those to fit inside any manageable ebuild."
@@ -58,7 +61,7 @@ pkg_setup() {
export HOSTCC="$(tc-getBUILD_CC)"
# threading options
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
USE_THREAD=0
if use openmp; then
USE_THREAD=1; USE_OPENMP=1;