summaryrefslogtreecommitdiff
path: root/sci-libs/onnx/onnx-1.14.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-02 14:53:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-02 14:53:28 +0000
commit4eaeaf683cb193978f14d55e52ea834d32e8a089 (patch)
treecd23a4d91c322f29e5c001bc033a008e309831a4 /sci-libs/onnx/onnx-1.14.0-r2.ebuild
parente12724a13a1677867978f5ecd7fabda4eb1e3aa8 (diff)
gentoo auto-resync : 02:01:2024 - 14:53:28
Diffstat (limited to 'sci-libs/onnx/onnx-1.14.0-r2.ebuild')
-rw-r--r--sci-libs/onnx/onnx-1.14.0-r2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sci-libs/onnx/onnx-1.14.0-r2.ebuild b/sci-libs/onnx/onnx-1.14.0-r2.ebuild
deleted file mode 100644
index f3f43c3fddd3..000000000000
--- a/sci-libs/onnx/onnx-1.14.0-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_OPTIONAL=1
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 cmake
-
-DESCRIPTION="Open Neural Network Exchange (ONNX)"
-HOMEPAGE="https://github.com/onnx/onnx"
-SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-IUSE="python"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- )
- dev-libs/protobuf:=
-"
-DEPEND="${RDEPEND}"
-
-BDEPEND="python? (
- ${DISTUTILS_DEPS}
-)"
-
-PATCHES=( "${FILESDIR}"/${P}-cxx_14.patch )
-
-src_prepare() {
- cmake_src_prepare
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- mycmakeargs=(
- -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
- -DONNX_USE_LITE_PROTO=ON
- )
- cmake_src_configure
- use python && distutils-r1_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use python && CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
-}
-
-src_install() {
- cmake_src_install
- use python && distutils-r1_src_install
-}