summaryrefslogtreecommitdiff
path: root/sci-libs/octomap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-libs/octomap
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-libs/octomap')
-rw-r--r--sci-libs/octomap/Manifest2
-rw-r--r--sci-libs/octomap/octomap-1.9.5.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/octomap/Manifest b/sci-libs/octomap/Manifest
index 9437f5a73037..20043f85f1c0 100644
--- a/sci-libs/octomap/Manifest
+++ b/sci-libs/octomap/Manifest
@@ -1,5 +1,7 @@
AUX qglqt5.patch 8456 BLAKE2B babaed86e83e1403668b9c3c8cc693775f87783ab11f1f2bd1e3304dce7087186bad406909718244e1c7fa99101e95401c663022e23156a56230d4f5efac67de SHA512 7a9cbcfd49a84ac79b18c183c8d6f6244a76fa0acefdf4adff5f3952e2ad33c1ff1b8227a906d58f40bdff3d83c168e8af2c812e90837b1f98893afd060227ea
DIST octomap-1.9.0.tar.gz 1682421 BLAKE2B a299b4a956d5f9b6a67b05548f2239ad1181a4a1e673e5868d56d6e2d8f0101b2c75b114d1b7995c244c138fe04c8972104c25ca2f4ca6f75639f7326f06d8d7 SHA512 335a4ee3fe20f456afd2d8491f8fe6cfc2527d6e26aa690a69a39c1468e41d312fd84c85a1247deb11f513b9d50b8c69d34b46876f8257c205b0a99bac826237
+DIST octomap-1.9.5.tar.gz 1682781 BLAKE2B 1ced023160d10c424d4bff76a0481ffe6c87c5bf8133480afe6c47ee0ee116304a811293cc0af0b303ebcad370b7ce433e85212f070ac921a9c5be41905a94ea SHA512 e58c6d33c351b14e9596e18a8702715d167c136fd029b1078ddd13a5926fe451d3b619231b5a8ccfb64b6e5fc6db8b57e6ef329099828d2f5195c0988700b581
EBUILD octomap-1.9.0.ebuild 2015 BLAKE2B 2f504d3e91d967338f6831af1e93a38d3d59949f470f52e41a1ae2914fc52814c532bb8db3ae1a9f5e35ba4280c4643b29101c077c05847753eb229343f9effa SHA512 71af329bdd24260600d9fd79f474b0e587ce674c8746935eb673b50a9374347d340bf00313dc32b71575f3ea92900cacf04a2f369da47387010188da4a666899
+EBUILD octomap-1.9.5.ebuild 1690 BLAKE2B 6870c1c4024896a857df097d4c61620993b37aaaf4faed6167e79677407e61971bd74285dd69b1e1a73019ec402c17ab608a2617765a9845c4f673efd018f862 SHA512 edfee4f4e8e0a5c78c05c5b6e5dbb54c8a0a7e2b5311facfc091aceb0c5e97a87a704af9b13f0637ada6fc6d304106e0fadaebdc4aabacf6683f1f033a17dd68
EBUILD octomap-9999.ebuild 1975 BLAKE2B 63b34fd1c61e447e16c9e4b988e5b564d421cea9f15fad3a5e8579222c0f7f174e6c84167d7960c1e6e7d660aaa645ce88d92eba0ceb33c5254db3ef6bea7793 SHA512 018a25e757235bb8509c2e502bd87b286d484037aa4738e06014051675da58a24562580fc284276f18cbe2492779fa4214dd361aed49dbfa8170df6e81ea9f8d
MISC metadata.xml 703 BLAKE2B 52e5edafca7a58ff0efddeea0eb60894c9bd26c5360fb77c41982edf0b27dec9517bb0470049d92dee05cc242effc7bb2e253a275f6e5d422e7e214676f7ffe8 SHA512 66b3c9143aea83a044a719031b4eb0d140e599048885ca6bb02e74ebebbbd2e9abccf11dc0af32e6ce94d3849dcf639ebaf34ff2c8d6e34f32767e08e465c6b0
diff --git a/sci-libs/octomap/octomap-1.9.5.ebuild b/sci-libs/octomap/octomap-1.9.5.ebuild
new file mode 100644
index 000000000000..230100c81764
--- /dev/null
+++ b/sci-libs/octomap/octomap-1.9.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
+HOMEPAGE="http://octomap.github.io/"
+SRC_URI="https://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD qt5? ( GPL-2 )"
+SLOT="0/19"
+KEYWORDS="~amd64 ~arm"
+IUSE="qt5 dynamicEDT3D doc"
+
+RDEPEND="
+ qt5? (
+ virtual/opengl
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ x11-libs/libQGLViewer:=
+ )
+"
+BDEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+# https://github.com/OctoMap/octomap/issues/194
+PATCHES=( "${FILESDIR}/qglqt5.patch" )
+
+src_prepare() {
+ rm -r octovis/src/extern
+
+ sed --in-place \
+ --expression='s/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ */CMakeLists.txt */CMakeModules/InstallPkgConfigFile.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt5 ON OFF)"
+ "-DOCTOVIS_QT5=ON"
+ "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build docs docs_dynamicEDT3D
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc; then
+ docinto html/octomap
+ dodoc -r octomap/doc/html/*
+
+ docinto html/dynamicEDT3D
+ dodoc -r dynamicEDT3D/doc/html/*
+ fi
+
+ insinto /usr/share/ros_packages/${PN}
+ doins "${ED}/usr/share/${PN}/package.xml"
+
+ if use qt5; then
+ insinto /usr/share/ros_packages/octovis
+ doins "${ED}/usr/share/octovis/package.xml"
+ fi
+}
+
+src_test() {
+ # override parallel mode only for tests
+ local myctestargs=( "-j 1" )
+ cmake_src_test
+}