summaryrefslogtreecommitdiff
path: root/sci-libs/nfft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/nfft
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/nfft')
-rw-r--r--sci-libs/nfft/Manifest5
-rw-r--r--sci-libs/nfft/metadata.xml15
-rw-r--r--sci-libs/nfft/nfft-3.3.2.ebuild49
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/nfft/Manifest b/sci-libs/nfft/Manifest
new file mode 100644
index 000000000000..a428350cd034
--- /dev/null
+++ b/sci-libs/nfft/Manifest
@@ -0,0 +1,5 @@
+DIST nfft-3.3.2.tar.gz 2821259 SHA256 9dcebd905a82c4f0a339d0d5e666b68c507169d9173b66d5ac588aae5d50b57c SHA512 66bcd2439c9ba27063aa1db01c526a580c5c67938e2db332068ce20035ede1d8766e8f134a0e5dac5263aca14121573ca4f5a906b452c43f218636f5f6161c02 WHIRLPOOL 9e15d7517d504a37b15b221a850e0b6574aeefc9af70d2a265bd0f2aa37f8a498462697c5ab73c47a4487f58978cf0cdd74d58e3073dc2b54361f0a216aba8c5
+EBUILD nfft-3.3.2.ebuild 1211 SHA256 4d8c61453b7e6663f300c93e067349e767744515303dd406277809475d0cfa34 SHA512 cab2ec8d53fd04221644cecd228b899368ed7863cb8d4228bd021fa47f75ac54129e3decf44b224833960344f18945586d075523952b071c4a2fe07dec673d64 WHIRLPOOL 93a75c259a99e00a6c16b5911bd7eabb6a278e2a67a5ed5cd3733a356bd37af2ab62fb818967ea9ddc3c82966d580749db18eb2a1083e4b84cfe98fdda60520a
+MISC ChangeLog 2541 SHA256 8d726b330c5c67a9dab76c0406c4cad0fd9259013d83d664b1db9ea78d986de1 SHA512 c50d89b0d8fdcfab4614654063961429d7b101274c1e5a68d8c6ee17b6ad5327c3794bbbbfecbac8e41e4b8c041dba1644fd335d37be9babd00639516d8dfda4 WHIRLPOOL cc70f030f96b494474840c42e0133b00116af578d350458715a7e095f636b9fb0001025a656d5b189e64c287e2b6f706349b3af52bf61ec2a2f70897738ccead
+MISC ChangeLog-2015 452 SHA256 8901f6c0c4b689eca7ef6316e34b15cedc90571af3f3ae9f79d94d0cda32bd4c SHA512 5bc8fb61d7c60403de92ef8636039fd3d6f25db0f025b6a12e4873b7788e84419be12a44e041d78cc2ba82f6e8cca66edf443a3c602f7d27279a379ea8f80f11 WHIRLPOOL 7f0d44271ec284f5773485744b3ce9cb9a2d22b80d75c05216307ae38b490c6c820530a9dfcd2f66001d6dd61e5c1f567c2c2f62dae0db214ac61f5c99072656
+MISC metadata.xml 441 SHA256 fd1b58ecbfbe5c0df8e6771bfaf75d892bb3a604e472f8ee183028ffe62c67ce SHA512 72f45a8c112412d0a1db5265b29d4688263465d0039f3f178d7a44dbfb4c87336339c4517b5a948ba631248a27e0e727e92cb1617dbdfedf39910c0df44c6caa WHIRLPOOL 7ba5209cbf3b607a20cbcde91a625a402d4d2feffbdac3ae6198ab9bed783c844ab3fb0324a556e3587bb90baeb77c80e0f025d350f5cdc49c129ea762dde66c
diff --git a/sci-libs/nfft/metadata.xml b/sci-libs/nfft/metadata.xml
new file mode 100644
index 000000000000..b759151e3dc4
--- /dev/null
+++ b/sci-libs/nfft/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NFFT/nfft</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/nfft/nfft-3.3.2.ebuild b/sci-libs/nfft/nfft-3.3.2.ebuild
new file mode 100644
index 000000000000..8c5f1f54b675
--- /dev/null
+++ b/sci-libs/nfft/nfft-3.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="library for nonequispaced discrete Fourier transformations"
+HOMEPAGE="http://www-user.tu-chemnitz.de/~potts/nfft"
+SRC_URI="https://github.com/NFFT/nfft/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc openmp static-libs"
+
+RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ if ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+
+ if tc-is-clang; then
+ ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
+ ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
+ fi
+
+ die "need openmp capable compiler"
+ fi
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-all \
+ --enable-shared \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc || rm -r "${ED}/usr/share/doc/${P}/html" || die
+
+ # infft uses pkg-config to record its private dependencies
+ find "${ED}" -name '*.la' -delete || die
+}