summaryrefslogtreecommitdiff
path: root/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-01 08:13:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-01 08:13:46 +0100
commit48e7f15d37baf7167041b2ab0e2a19a703e5c99f (patch)
treea4ae631f4b109859ab021cfc9d048e9a81a252ce /sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
parentde6c40224da664deb650b25efd11f41044602c76 (diff)
gentoo auto-resync : 01:04:2024 - 08:13:46
Diffstat (limited to 'sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild')
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
index f9c020fa3521..9b44a0997205 100644
--- a/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.6.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
FORTRAN_STANDARD="77 90"
-inherit cmake fortran-2
+inherit cmake flag-o-matic fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -25,6 +25,11 @@ DEPEND="
BDEPEND="doc? ( app-text/doxygen[dot] )"
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/927588
+ # https://github.com/Unidata/netcdf-fortran/issues/437
+ filter-lto
+
local mycmakeargs=(
-DDISABLE_ZSTANDARD_PLUGIN=$(usex !zstd)
-DBUILD_EXAMPLES=$(usex examples)