summaryrefslogtreecommitdiff
path: root/sci-libs/nanoflann/nanoflann-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /sci-libs/nanoflann/nanoflann-9999.ebuild
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'sci-libs/nanoflann/nanoflann-9999.ebuild')
-rw-r--r--sci-libs/nanoflann/nanoflann-9999.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/sci-libs/nanoflann/nanoflann-9999.ebuild b/sci-libs/nanoflann/nanoflann-9999.ebuild
index 2c8467c00469..4db99558405a 100644
--- a/sci-libs/nanoflann/nanoflann-9999.ebuild
+++ b/sci-libs/nanoflann/nanoflann-9999.ebuild
@@ -8,11 +8,9 @@ inherit cmake-utils
DESCRIPTION="C++ header-only library for Nearest Neighbor (NN) search wih KD-trees"
HOMEPAGE="https://github.com/jlblancoc/nanoflann"
-if [[ ${PV} = *9999* ]]; then
+if [[ ${PV} = *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/jlblancoc/nanoflann.git"
- SRC_URI=""
- KEYWORDS=""
else
SRC_URI="https://github.com/jlblancoc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -22,20 +20,16 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-cpp/eigen:*"
+RDEPEND="dev-cpp/eigen:3"
DEPEND="${RDEPEND}"
src_prepare() {
- eapply_user
+ cmake-utils_src_prepare
# do not compile examples
- sed -ie 's/add_subdirectory(examples)//g' CMakeLists.txt || die "sed failed"
+ cmake_comment_add_subdirectory examples
}
src_test() {
- cd "${BUILD_DIR}" && emake -j1 test
-}
-
-src_compile() {
- :
+ "${CMAKE_MAKEFILE_GENERATOR}" -C "${BUILD_DIR}" -j1 test
}