summaryrefslogtreecommitdiff
path: root/sci-libs/m4ri
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-libs/m4ri
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-libs/m4ri')
-rw-r--r--sci-libs/m4ri/Manifest3
-rw-r--r--sci-libs/m4ri/m4ri-20140914.ebuild52
-rw-r--r--sci-libs/m4ri/metadata.xml33
3 files changed, 88 insertions, 0 deletions
diff --git a/sci-libs/m4ri/Manifest b/sci-libs/m4ri/Manifest
new file mode 100644
index 000000000000..78ff938b663b
--- /dev/null
+++ b/sci-libs/m4ri/Manifest
@@ -0,0 +1,3 @@
+DIST m4ri-20140914.tar.gz 457978 BLAKE2B eadba6d1a751cb49cef25cc7726d87aa5746b23ad0a3b9bd274735a71da43ec4751fb655f91f3748f082369875508db365595f8443d77ae9645b3e4199d4f204 SHA512 efdd4ffa194d2d2b64a23a833420926613e74072ce62b2b06d768d157e134a615d88b93ed08d9f51f0fd14d686fd068523d1dc2c7cd9fb87108c96a4a11f4643
+EBUILD m4ri-20140914.ebuild 1479 BLAKE2B cec3f194a66b82b09fd29aba43573028bfdbc0341f8e594544570a7a7c7945e7db069427823460421e7b3650bbaf9cf21d3b0ccf2a555f8f19ee42c93e92cf68 SHA512 d74486068c8987d0fca7db524c311b53a87d8c05826cb322fb009f01b0c8f1a4901ef85a4d07887546e43680e81d70fb9f587ac78f7527072fc57c5eb5424a02
+MISC metadata.xml 1159 BLAKE2B 4a51b94a6a8d48e39412d90a249ef2038bcaac90653cbc187226842f33f5a8c75704b2671dc5fc63650cf4a57f77d7724409eca8d5822c7689eda3e5386902da SHA512 40d6e3dce814e11ced9da6874af71022dad66ff1b0511024a9033706f1b43ce741f418086d9beb276e09578db2acc1708758f71cdb168384d59f85627505e643
diff --git a/sci-libs/m4ri/m4ri-20140914.ebuild b/sci-libs/m4ri/m4ri-20140914.ebuild
new file mode 100644
index 000000000000..2e7cb8b7207e
--- /dev/null
+++ b/sci-libs/m4ri/m4ri-20140914.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Method of four russian for inversion (M4RI)"
+HOMEPAGE="https://bitbucket.org/malb/m4ri"
+
+# We use the SageMath tarball instead of the one from bitbucket because
+# the bitbucket releases don't contain the "make dist" stuff and we
+# would need autotools.eclass to generate it.
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug openmp cpu_flags_x86_sse2 png static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="png? ( media-libs/libpng:= )"
+RDEPEND="${DEPEND}"
+
+# NEWS and ChangeLog are empty as of 2020-01-01, and README.md
+# didn't make it into the release tarball.
+DOCS=( AUTHORS )
+
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # when using openmp and -O0 the testsuite fails
+ # https://github.com/cschwan/sage-on-gentoo/issues/475
+ use openmp && replace-flags -O0 -O1
+
+ # kiwifb: cachetune option is not available, because it kills (at
+ # least my) X when I switch from yakuake to desktop
+ econf \
+ $(use_enable debug) \
+ $(use_enable openmp) \
+ $(use_enable png) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/m4ri/metadata.xml b/sci-libs/m4ri/metadata.xml
new file mode 100644
index 000000000000..9807bfb0055f
--- /dev/null
+++ b/sci-libs/m4ri/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <longdescription>
+ M4RI is a library for fast arithmetic with dense matrices over
+ F2. The name M4RI comes from the first implemented algorithm: The
+ "Method of the Four Russians" inversion algorithm published by
+ Gregory Bard. This algorithm in turn is named after the 'Method of
+ the Four Russians' multiplication algorithm which is probably
+ better referred to as Kronrod's method.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="bitbucket">malb/m4ri</remote-id>
+ </upstream>
+</pkgmetadata>