summaryrefslogtreecommitdiff
path: root/sci-libs/lis/lis-1.6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/lis/lis-1.6.5.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/lis/lis-1.6.5.ebuild')
-rw-r--r--sci-libs/lis/lis-1.6.5.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/sci-libs/lis/lis-1.6.5.ebuild b/sci-libs/lis/lis-1.6.5.ebuild
index 75c41a7dd9e8..27d638831af1 100644
--- a/sci-libs/lis/lis-1.6.5.ebuild
+++ b/sci-libs/lis/lis-1.6.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,21 +19,12 @@ DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-1.6.2-autotools.patch )
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp && FORTRAN_NEED_OPENMP=1
use fortran && fortran-2_pkg_setup
}