summaryrefslogtreecommitdiff
path: root/sci-libs/linbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sci-libs/linbox
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sci-libs/linbox')
-rw-r--r--sci-libs/linbox/Manifest4
-rw-r--r--sci-libs/linbox/files/linbox-1.6.3-pc.patch25
-rw-r--r--sci-libs/linbox/linbox-1.6.3.ebuild93
-rw-r--r--sci-libs/linbox/metadata.xml39
4 files changed, 161 insertions, 0 deletions
diff --git a/sci-libs/linbox/Manifest b/sci-libs/linbox/Manifest
new file mode 100644
index 000000000000..b2db4b133845
--- /dev/null
+++ b/sci-libs/linbox/Manifest
@@ -0,0 +1,4 @@
+AUX linbox-1.6.3-pc.patch 1082 BLAKE2B 7d5b055c0622b61245f193eb39d7e52951262c56456dceba5b3e72f54add82b2fc1660c4590eba2c4a97009bd78119893bfccb0909ed5374752f4bf563e75655 SHA512 5739738de34c28fb9970a869ee97a6ab528fd48e3f8b3d82f39966959fa97d6076a44263678d25c06bea3c46e06c8869ba4ea94484d5b57aee3a302df49fd06b
+DIST linbox-1.6.3.tar.gz 1968034 BLAKE2B 55fb83db7da375d8d97f2567c6a120ac48fefc41eb02db68152cc32f1f16009b8c8108a07bbc68087ad2ef3279108db61b48b805c9ce39f4c5f0072ab6e96304 SHA512 ccef3b4c7b9d8f999e5e4ce4e544f22cd869154513827501ecb7e1abf132ff585dfb3315cced963abe842feecda9331dda9081efb3948987365d338223a8305c
+EBUILD linbox-1.6.3.ebuild 3342 BLAKE2B 2907fff7074519568eef7747acccaad85c60ce62aea7c8d83160d050f52e2a701e1d96d019eb86526675a9cb2f5d7b0a8f0fea6a0c4c04f0d4f7baf59690522f SHA512 2fc91cb26475b5f7a5fd59e1990872c31fd6285fef6882568b9a9280c0e500b18f2fd698e0835e9b7c7435d1215b3f56fa30847f1922d7504a9b2285d12a22d8
+MISC metadata.xml 1242 BLAKE2B 456a3155a1206586e04e144f133659a107154d1064afc8cbb210eb5fb6930792e846e0ad58e55d20738f4a7fb078158c2d8398379f81d56b90c9aa7d09645426 SHA512 86b2f86c9f15b00fdd57c5041828f1b3a309d616b0580eee878a6ccbf917f2b500aae81c0cc96c4d10b5b40429b3bf997f0ea3468878d7b8e8b08c4624977b77
diff --git a/sci-libs/linbox/files/linbox-1.6.3-pc.patch b/sci-libs/linbox/files/linbox-1.6.3-pc.patch
new file mode 100644
index 000000000000..de0025108b89
--- /dev/null
+++ b/sci-libs/linbox/files/linbox-1.6.3-pc.patch
@@ -0,0 +1,25 @@
+From 8fb95a5dba51fbfcd37db10da4db69d518f7b0f4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fran=C3=A7ois=20Bissey?= <frp.bissey@gmail.com>
+Date: Fri, 24 Apr 2020 14:10:05 +1200
+Subject: [PATCH] Remove @LINBOX_SAGE@ from linbox.pc.in. linbox_sage is gone
+ and the string stays as garbage in the final .pc file.
+
+---
+ linbox.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/linbox.pc.in b/linbox.pc.in
+index f54285e..1f83834 100644
+--- a/linbox.pc.in
++++ b/linbox.pc.in
+@@ -9,6 +9,6 @@ Description: Exact Linear Algebra library
+ URL: http://github.com/linbox-team/linbox
+ Version: @VERSION@
+ Requires: fflas-ffpack >= 2.4.0, givaro >= 4.1.0
+-Libs: -L${libdir} -llinbox @LINBOXSAGE_LIBS@ @NTL_LIBS@ @MPFR_LIBS@ @FPLLL_LIBS@ @IML_LIBS@ @FLINT_LIBS@ @OCL_LIBS@
++Libs: -L${libdir} -llinbox @NTL_LIBS@ @MPFR_LIBS@ @FPLLL_LIBS@ @IML_LIBS@ @FLINT_LIBS@ @OCL_LIBS@
+ Cflags: @DEFAULT_CFLAGS@ -DDISABLE_COMMENTATOR -I${includedir} @NTL_CFLAGS@ @MPFR_CFLAGS@ @FPLLL_CFLAGS@ @IML_CFLAGS@ @FLINT_CFLAGS@
+ \-------------------------------------------------------
+--
+2.26.2
+
diff --git a/sci-libs/linbox/linbox-1.6.3.ebuild b/sci-libs/linbox/linbox-1.6.3.ebuild
new file mode 100644
index 000000000000..db82ccb781cd
--- /dev/null
+++ b/sci-libs/linbox/linbox-1.6.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ template library for integer and finite-field linear algebra"
+HOMEPAGE="https://linalg.org/"
+SRC_URI="https://github.com/linbox-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc opencl openmp static-libs cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+# The project README says that gmp, givaro, and blas/lapack are required
+# transitively via fflas-ffpack, but that's not true. The build system
+# checks for them, and `git grep` shows that they're used directly.
+DEPEND="dev-libs/gmp[cxx]
+ =sci-libs/givaro-4.1*
+ =sci-libs/fflas-ffpack-2.4*
+ virtual/cblas
+ virtual/lapack
+ opencl? ( virtual/opencl )
+ dev-libs/ntl:=
+ sci-libs/iml
+ dev-libs/mpfr:=
+ sci-mathematics/flint"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.3-pc.patch" )
+
+pkg_pretend() {
+ [[ "${MERGE_TYPE}" != "binary" ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ #
+ # The --with-all flag includes,
+ #
+ # --with-givaro: used for finite fields, integer, etc. (required)
+ # --with-fflas-ffpack: small field dense linear algebra (required)
+ # --with-ntl: used for finite field, polynomial arithmetic (optional)
+ # --with-iml: used for fast integer/rational linear algebra (optional)
+ # --with-mpfr: not sure, doesn't seem to be used? (optional)
+ # --with-flint: used in algorithms/matrix-blas3 once (optional)
+ # --with-fplll: an fplll interface not directly used (optional)
+ # --with-doxygen: needed with --enable-doc to build them (optional)
+ #
+ # Some of these could be behind USE flags, but the ./configure output
+ # says that they're "not yet mandatory," which makes me think we might
+ # be overcomplicating things to make them optional right now.
+ #
+ # Note: after v1.6.3, we'll need to append --without-archnative to
+ # these flags to avoid -march=native being appended by default.
+ #
+ econf \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-all="${EPREFIX}"/usr \
+ --without-fplll \
+ $(use_enable doc) \
+ $(use_enable openmp) \
+ $(use_with opencl ocl) \
+ $(use_enable cpu_flags_x86_fma3 fma) \
+ $(use_enable cpu_flags_x86_fma4 fma4) \
+ $(use_enable cpu_flags_x86_sse3 sse) \
+ $(use_enable cpu_flags_x86_sse3 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_sse4_2 sse42) \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable cpu_flags_x86_avx2 avx2) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+ if use doc; then
+ # These files are used for incremental doxygen builds but aren't
+ # part of the final output. Check on
+ #
+ # https://github.com/linbox-team/linbox/issues/252
+ #
+ # periodically to see if this is pointless.
+ find "${ED}/usr/share/doc/${PF}" -type f -name '*.md5' -delete || die
+ find "${ED}/usr/share/doc/${PF}" -type f -name '*.map' -delete || die
+ fi
+}
diff --git a/sci-libs/linbox/metadata.xml b/sci-libs/linbox/metadata.xml
new file mode 100644
index 000000000000..b8fdd1af15d4
--- /dev/null
+++ b/sci-libs/linbox/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <use>
+ <flag name="opencl">
+ Enable the use of OpenCL in LinBox
+ </flag>
+ </use>
+
+ <longdescription lang="en">
+ LinBox is a C++ template library for exact, high-performance
+ linear algebra computation with dense, sparse, and structured
+ matrices over the integers and over finite fields. LinBox relies
+ on closely aligned libraries fflas-ffpack (exact dense matrix
+ linear algebra kernels), and Givaro (finite fields, integers, and
+ polynomials).
+ </longdescription>
+
+ <upstream>
+ <remote-id type="github">linbox-team/linbox</remote-id>
+ </upstream>
+</pkgmetadata>