summaryrefslogtreecommitdiff
path: root/sci-libs/libpdb++/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libpdb++/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libpdb++/files')
-rw-r--r--sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch b/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
new file mode 100644
index 000000000000..3600481f4c72
--- /dev/null
+++ b/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
@@ -0,0 +1,54 @@
+ Makefile | 20 +++++++++++++-------
+ 1 file changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index bbf0778..1dc6c62 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,22 +4,22 @@
+ # On System V machines, RANLIB should be ':'
+ #
+ SHELL = /bin/sh
+-RANLIB = :
++#RANLIB = :
+
+-CXX = gcc -felide-constructors
++CXX ?= g++
+ #CXX = CC
+
+ .SUFFIXES: .cc
+
+ .cc.o:
+- $(CXX) $(CCFLAGS) -c $< -o $@
++ $(CXX) $(CXXFLAGS) -fPIC -felide-constructors -c $< -o $@
+
+ OPT = -O
+ DEBUG =
+ CCFLAGS = $(OPT) $(DEBUG)
+ LIBRARY = pdb++
+
+-LIBARCH = lib$(LIBRARY).a
++LIBARCH = lib$(LIBRARY)
+ OBJS = pdb_read.o pdb_sprntf.o pdb_sscanf.o pdb_chars.o \
+ pdb_type.o pdb++.o pdbinput.o
+ SRCS = pdb_read.cc pdb_sprntf.cc pdb_sscanf.cc pdb_chars.cc \
+@@ -30,10 +30,16 @@ all: $(LIBARCH)
+ install: $(LIBARCH)
+ install -F /usr/local/lib $(LIBARCH)
+
+-$(LIBARCH): $(OBJS)
++$(LIBARCH).a: $(OBJS)
+ @echo "Loading $(LIBARCH) ... "
+- @ar cru $(LIBARCH) $(OBJS)
+- @$(RANLIB) $(LIBARCH)
++ $(AR) cru $@ $(OBJS)
++ $(RANLIB) $@
++ @echo "done"
++
++$(LIBARCH).so: $(OBJS)
++ $(CXX) $(LDFLAGS) -shared -Wl,--soname,libpdb++.so.0 -o libpdb++.so.0.1 $(OBJS)
++ ln -sf libpdb++.so.0.1 libpdb++.so.0
++ ln -sf libpdb++.so.0.1 libpdb++.so
+ @echo "done"
+
+ clean:; @rm -f $(OBJS)