summaryrefslogtreecommitdiff
path: root/sci-libs/libgenome/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libgenome/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libgenome/files')
-rw-r--r--sci-libs/libgenome/files/libgenome-1.3-fix-c++14.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/libgenome/files/libgenome-1.3-fix-c++14.patch b/sci-libs/libgenome/files/libgenome-1.3-fix-c++14.patch
new file mode 100644
index 000000000000..ffe30ef91fa2
--- /dev/null
+++ b/sci-libs/libgenome/files/libgenome-1.3-fix-c++14.patch
@@ -0,0 +1,30 @@
+Fix building with C++14, which errors out due to collisions with internal abs() function.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594372
+
+--- a/libGenome/gnDefs.h
++++ b/libGenome/gnDefs.h
+@@ -175,13 +175,6 @@
+
+ #define CONTIG_SECTION_SIZE 3
+
+-// some compilers don't have abs() for 64 bit ints
+-#if (defined(__GNUG__) && ( __GNUC__ <= 2 )) || defined(__INTEL_COMPILER) || (defined _MSC_VER && defined __cplusplus)
+-
+-int64 abs( int64 a );
+-
+-#endif
+-
+ #ifdef __cplusplus
+ namespace genome {
+ #endif
+--- a/libGenome/Makefile.am
++++ b/libGenome/Makefile.am
+@@ -29,7 +29,7 @@
+ gnGenomeSpec.cpp gnLocation.cpp \
+ gnRAWSource.cpp gnBaseFeature.cpp gnSEQSource.cpp gnSequence.cpp \
+ gnContigSpec.cpp gnSourceHeader.cpp gnException.cpp \
+-gnFastTranslator.cpp gnPosSpecificTranslator.cpp gnDefs.cpp
++gnFastTranslator.cpp gnPosSpecificTranslator.cpp
+
+ library_includedir=$(includedir)/$(GENERIC_LIBRARY_NAME)-$(GENERIC_API_VERSION)/$(GENERIC_LIBRARY_NAME)
+