summaryrefslogtreecommitdiff
path: root/sci-libs/libecpint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-libs/libecpint
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-libs/libecpint')
-rw-r--r--sci-libs/libecpint/Manifest3
-rw-r--r--sci-libs/libecpint/libecpint-1.0.2.ebuild27
-rw-r--r--sci-libs/libecpint/metadata.xml17
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/libecpint/Manifest b/sci-libs/libecpint/Manifest
new file mode 100644
index 000000000000..289b2fc57399
--- /dev/null
+++ b/sci-libs/libecpint/Manifest
@@ -0,0 +1,3 @@
+DIST libecpint-1.0.2.tar.gz 1161801 BLAKE2B 98b9264055bc9dab86ad54921f65380bca6cf96a2e6000bc061998367b3eeaffe122fa03ed83c75deb568ee7cce49ff85b97909bd57ae057a189025421dee82e SHA512 adf9394628a39d1e07e4f02bf4fad1c3d19cbfd9a9aa123d6151dddb78c7ef2c2cab07bc7060dba1d5114756c03964c2bd237c82203a1efb38b9facaaa24c74a
+EBUILD libecpint-1.0.2.ebuild 614 BLAKE2B cfa9e63c58e931e386cd1fa89252621ae2056ec93a10e8b1dd0ca3c87c14a0973c69707844f26710cf90b5561b858d9ee87abbeb0c6cceee780ec787cb004978 SHA512 aef1b9a6f9ed45d329af61014925b8fc17336bdb12a66b283100856eab619cf4005a2b0974f021452c1f1c59c484d2076439138c1865a1a535f027ed3276b16d
+MISC metadata.xml 636 BLAKE2B 4ef2fae4bda3d954677ec576703eb777c947212819c38ef1181c50f4bd7e128c342547d4c35e61ecac57852f21108265410034e2a71f546b8101a587e9428840 SHA512 c74b750861f6bd26d0f6aef880d055cc418216e4e8a17b45bfe51caee453ff0214fe7557b59b38f71dfcf13063ebf0c93ed4c29efdbeb5528172abf087d7e60c
diff --git a/sci-libs/libecpint/libecpint-1.0.2.ebuild b/sci-libs/libecpint/libecpint-1.0.2.ebuild
new file mode 100644
index 000000000000..40c0946f2990
--- /dev/null
+++ b/sci-libs/libecpint/libecpint-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Efficient evaluation of integrals over ab initio effective core potentials"
+HOMEPAGE="https://github.com/robashaw/libecpint"
+SRC_URI="https://github.com/robashaw/libecpint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/pugixml
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ mycmakeargs=(
+ -DLIBECPINT_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/libecpint/metadata.xml b/sci-libs/libecpint/metadata.xml
new file mode 100644
index 000000000000..0802ee79be89
--- /dev/null
+++ b/sci-libs/libecpint/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Libecpint is a C++ library for the efficient evaluation of integrals over ab
+ initio effective core potentials, using a mixture of generated, recursive
+ code and Gauss-Chebyshev quadrature. It is designed to be standalone and
+ generic.
+</longdescription>
+ <upstream>
+ <remote-id type="github">robashaw/libecpint</remote-id>
+ </upstream>
+</pkgmetadata>