summaryrefslogtreecommitdiff
path: root/sci-libs/libdap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /sci-libs/libdap
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'sci-libs/libdap')
-rw-r--r--sci-libs/libdap/Manifest2
-rw-r--r--sci-libs/libdap/libdap-3.18.1.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/sci-libs/libdap/Manifest b/sci-libs/libdap/Manifest
index 949d49b2ea2f..bf106034ac1c 100644
--- a/sci-libs/libdap/Manifest
+++ b/sci-libs/libdap/Manifest
@@ -5,5 +5,5 @@ AUX libdap-3.18.1-disable-net-tests.patch 1281 BLAKE2B fd00fb1920a8440a633aa9595
AUX libdap-3.18.1-fix-buildsystem.patch 621 BLAKE2B 09ec113a8860388d9d1150b7111352316b52d8307e29c3db2d6de00d2bc912d46d7c27f2e0f3429382691ff2d3696252c019554c28d8c92ea8f74db9c7877e5b SHA512 4aeb883dd338ed3c27ab2fe217d8419c8e4130485eec11f12b75dad6979034b4cbe251b4f81d21280a05257cd7bd5e56fdbb20b08f48ac0d48822024cf00d9bb
AUX libdap-3.18.1-fix-c++14.patch 2287 BLAKE2B 2d6c036ab9ad4d611215de48b4288aa93868f3411d5637fcde7757ada661319472827bc4eea7084f925ecd9f9561d2156a4add8f5eb04693b4eb687f02efc398 SHA512 6bd2722f16cd3491922b43040148efb09dcf66f2403bcc8caae028d3497a5c864d6539b980c32cda01f35fffc2c724b68d20042f8d341f0a3a50c8fa78670535
DIST libdap-3.18.1.tar.gz 2209343 BLAKE2B 0b71f5a557315a1481f45b465a73d62e8bf44c78c7b0d257f56c758a63137eca3777a1e2e9ef1e7dc3e2c434709f238fc7ed40e56f61eb89f8d5b47af7504efa SHA512 a1d06bbbad654718bbf9980dc0943935089c09772678f6457d4de8a9d37f1ce33c0e1cab4c5eefec6f9e159028b194d6e3a6021597276b233eda52603ae8dd38
-EBUILD libdap-3.18.1.ebuild 1095 BLAKE2B 3b8fabafe6098b821d37d73b151f9fb2df0ec83aac69b161c154f0fa116230afd46c94b43ca47cfa146c39237ad76b968fccbbf19e0c8c84ef2b6ff8afd1f53d SHA512 10f6e2e7070b7bae860043a15cbb4d570f68a9f0c265eef4416aa4400a8748878773b3d30b3a59f4fdd6bfa9d0cced7064974173d383bdab62334ec01e5216b8
+EBUILD libdap-3.18.1.ebuild 1151 BLAKE2B ea8b98ce07887d2e5d06680ae4d5d881deabaa7c867e7dcda481ede42906c039a2f24f4d5606ec3f7c262975103c936c339f6926e5883110794f928a573b1c95 SHA512 1580012d315a89a770513d7beb940a603fb581ec935da4617825e77526c9a0ddcec60024fe2ca043ffe94d56428aacd7d28fa1a1d68059de8f7025a68c1dffe4
MISC metadata.xml 772 BLAKE2B 93699e5e75c2fffc660963cbc98fd31194553489cd52954c67f79b1b429077e46f66cbf9e6ba170a8e1c9a8213a5e9451350de461d7afe136ba1db88396a9d61 SHA512 277e96ec4eef7a080303e3b3b054d51c017ef2227644ed2d78a35d5c873f085f4524aa14b4f0f523a3d501c96a1f078032941d62005721e8264e2c5d625182eb
diff --git a/sci-libs/libdap/libdap-3.18.1.ebuild b/sci-libs/libdap/libdap-3.18.1.ebuild
index b0a4bfc02ba2..c0680c183d37 100644
--- a/sci-libs/libdap/libdap-3.18.1.ebuild
+++ b/sci-libs/libdap/libdap-3.18.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
HOMEPAGE="http://opendap.org/"
@@ -38,6 +38,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619144
+ append-cxxflags -std=c++14
+
econf \
--enable-shared \
$(use_enable static-libs static)