summaryrefslogtreecommitdiff
path: root/sci-libs/libccd/libccd-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libccd/libccd-2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libccd/libccd-2.0.ebuild')
-rw-r--r--sci-libs/libccd/libccd-2.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/libccd/libccd-2.0.ebuild b/sci-libs/libccd/libccd-2.0.ebuild
new file mode 100644
index 000000000000..894309a26239
--- /dev/null
+++ b/sci-libs/libccd/libccd-2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/danfis/libccd"
+fi
+
+inherit ${SCM} cmake-utils toolchain-funcs
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="http://libccd.danfis.cz/files/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for collision detection between two convex shapes"
+HOMEPAGE="http://libccd.danfis.cz/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="double doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+DOCS=( README )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCCD_DOUBLE=$(usex double TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${S}/doc"
+ emake SPHINXBUILD=sphinx-build html
+ fi
+}
+
+src_test() {
+ cd src/testsuites
+ tc-export CC
+ LDFLAGS="-L${BUILD_DIR} ${LDFLAGS}" \
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" \
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${S}/doc/_build/html/"*
+}