summaryrefslogtreecommitdiff
path: root/sci-libs/lapack/lapack-3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 17:40:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 17:40:55 +0000
commit8294b197c0de9084d8ac8510382353ea4c177b87 (patch)
tree588533368704fdb760c55c9d15e246a827bc3e3d /sci-libs/lapack/lapack-3.11.ebuild
parent73c06e01ebc820f47f0140310b8a096e9d20877b (diff)
gentoo auto-resync : 28:02:2024 - 17:40:54
Diffstat (limited to 'sci-libs/lapack/lapack-3.11.ebuild')
-rw-r--r--sci-libs/lapack/lapack-3.11.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-libs/lapack/lapack-3.11.ebuild b/sci-libs/lapack/lapack-3.11.ebuild
index 7e2764d7f209..91d893cac281 100644
--- a/sci-libs/lapack/lapack-3.11.ebuild
+++ b/sci-libs/lapack/lapack-3.11.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Some additional tests are run if Python is found
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake fortran-2 python-any-r1
+inherit cmake flag-o-matic fortran-2 python-any-r1
DESCRIPTION="BLAS,CBLAS,LAPACK,LAPACKE reference implementations"
HOMEPAGE="https://www.netlib.org/lapack/"
@@ -39,6 +39,11 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/878891
+ # https://github.com/Reference-LAPACK/lapack/issues/990
+ filter-lto
+
local mycmakeargs=(
-DCBLAS=ON
-DLAPACKE=$(usex lapacke)