summaryrefslogtreecommitdiff
path: root/sci-libs/jiwer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-14 22:02:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-14 22:02:07 +0100
commit78db24b58a7f75bf18548cbf5c3b210f2f33f2f4 (patch)
tree53f180d30387a94fd028e0c5a10635621ebeb98f /sci-libs/jiwer
parent153fd195574cc30040446316bb666af0e58d985f (diff)
gentoo auto-resync : 14:05:2023 - 22:02:07
Diffstat (limited to 'sci-libs/jiwer')
-rw-r--r--sci-libs/jiwer/Manifest4
-rw-r--r--sci-libs/jiwer/files/jiwer-3.0.1-tests.patch31
-rw-r--r--sci-libs/jiwer/jiwer-3.0.1.ebuild27
-rw-r--r--sci-libs/jiwer/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/jiwer/Manifest b/sci-libs/jiwer/Manifest
new file mode 100644
index 000000000000..ca6738a490e3
--- /dev/null
+++ b/sci-libs/jiwer/Manifest
@@ -0,0 +1,4 @@
+AUX jiwer-3.0.1-tests.patch 790 BLAKE2B dda351c97d0807c327d0438eb3849e15a9b30753c3e7350fa522ebc6d861fa5f3ecbf01b9c55bfad921e6a605178c0175ead21f450677518da26de9faf2120d4 SHA512 e8b8bacbb051b20e8b6cf9e93542dd31828cc052fea773335d7ec4b8a27d2c06c2ba7a8a58f91d02434907aeb1d499e411d69e6daf56cb3420a3ccfbcc51ea35
+DIST jiwer-3.0.1.gh.tar.gz 24015 BLAKE2B 634b1c7613a29ee492a108c09d3adeeec6ce975e3663505db5f02258f37f53933f0c6e12c9f0ab48274798bdc130e8ceb5d201b3090af3b9fcbba3ccf66a261e SHA512 9a455ec8687947531dc18f89aa898d7906e1e94f803fa05f3e4689b074e05a13b3b653cbc621c723c8d9776c0c787d7a4978eca3efb90c4abded7e7f6b13ca9e
+EBUILD jiwer-3.0.1.ebuild 608 BLAKE2B bdd1fd3afa9dc26bd7dedb13c6b82886c710588def8e3a7055053f9bcc5cce873ccf32aafab98e71cd6372bf5cb35a14fa32154443f513d4820526afea1db531 SHA512 65a411b1114412222f6b18118264cf4b2a35874ccfca6f35f9b42361fb083da019480dcc638da157d56ffe997320d5848d78542f08b70bca88f02b0bb8f69e92
+MISC metadata.xml 367 BLAKE2B 474dd86fe7addc587bea0b16430e99e5c69148099c1fba0cd58022dbe83411e83e1455320ed4ea1a54c4c74932bcbaa5e793223023d795639babb64d7751a876 SHA512 9bbed0bbfca58ff29129a6e3cceaa075da22576c840595e0a1471baa8e8e00f4f3407c88bbd46755c498a058d89220e3c0864157fd61850ab4c73d3f2c4a110e
diff --git a/sci-libs/jiwer/files/jiwer-3.0.1-tests.patch b/sci-libs/jiwer/files/jiwer-3.0.1-tests.patch
new file mode 100644
index 000000000000..cfd9530985a3
--- /dev/null
+++ b/sci-libs/jiwer/files/jiwer-3.0.1-tests.patch
@@ -0,0 +1,31 @@
+--- a/tests/test_speed.py 2023-05-14 18:22:53.206560417 +0200
++++ b/tests/test_speed.py 2023-05-14 18:24:35.611996479 +0200
+@@ -1,4 +1,6 @@
+ from jiwer import wer
++import pytest
++
+
+
+ def perform_computation(num_sentences):
+@@ -8,17 +10,21 @@
+ wer(truth, hypo)
+
+
++@pytest.mark.skip(reason="require pytest-benchmark")
+ def test_speed_n1(benchmark):
+ benchmark(perform_computation, 1)
+
+
++@pytest.mark.skip(reason="require pytest-benchmark")
+ def test_speed_n10(benchmark):
+ benchmark(perform_computation, 10)
+
+
++@pytest.mark.skip(reason="require pytest-benchmark")
+ def test_speed_n100(benchmark):
+ benchmark(perform_computation, 100)
+
+
++@pytest.mark.skip(reason="require pytest-benchmark")
+ def test_speed_n1000(benchmark):
+ benchmark(perform_computation, 1000)
diff --git a/sci-libs/jiwer/jiwer-3.0.1.ebuild b/sci-libs/jiwer/jiwer-3.0.1.ebuild
new file mode 100644
index 000000000000..dcf61747a15a
--- /dev/null
+++ b/sci-libs/jiwer/jiwer-3.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Evaluate an automatic speech recognition system"
+HOMEPAGE="
+ https://github.com/jitsi/jiwer
+ https://pypi.org/project/jiwer/
+"
+SRC_URI="https://github.com/jitsi/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+BDEPEND="test? (
+ dev-python/rapidfuzz[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
diff --git a/sci-libs/jiwer/metadata.xml b/sci-libs/jiwer/metadata.xml
new file mode 100644
index 000000000000..183cb49efbc4
--- /dev/null
+++ b/sci-libs/jiwer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jiwer</remote-id>
+ <remote-id type="github">jitsi/jiwer</remote-id>
+ </upstream>
+</pkgmetadata>