summaryrefslogtreecommitdiff
path: root/sci-libs/itpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/itpp
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/Manifest5
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r1.ebuild52
-rw-r--r--sci-libs/itpp/metadata.xml19
3 files changed, 76 insertions, 0 deletions
diff --git a/sci-libs/itpp/Manifest b/sci-libs/itpp/Manifest
new file mode 100644
index 000000000000..81938c85f123
--- /dev/null
+++ b/sci-libs/itpp/Manifest
@@ -0,0 +1,5 @@
+DIST itpp-4.3.1.tar.bz2 1289687 SHA256 50717621c5dfb5ed22f8492f8af32b17776e6e06641dfe3a3a8f82c8d353b877 SHA512 b46d048fa7f33e80d2291a5e38e205c159791ea200f92c70d69e8ad8447ac2f0c847fece566a99af739853a1643cb16e226b4200c8bf115417f324e6d38c66bd WHIRLPOOL e4791babcdb9e874a29b8f628af000e93fc316a7da0199713e7b840317d1b1109e4350c7582a3f88db3fe8be03ff8ee93b40712b77f61faa155acc668f39c0e0
+EBUILD itpp-4.3.1-r1.ebuild 1313 SHA256 34f9f091e800f9f935963a581cd3574c5fbab9a72cf89f6e761554a401a82e09 SHA512 09e1b8bc70c37b7ea1bd92a280f9b2b880c0fb0b8cb5d55f806b3886ac1ed1923c74580203296261fb99410173a9df7b9c3f755c0df98b4367bc057adea0f464 WHIRLPOOL 90c84e1356f45dab29d6a55f72e885d08d8a721fe6b0300e614c12a17b71ebeb4245c66d52f4b0a2fbe25ee40078a9ae5c237f7863946ee10bd2964429d8521e
+MISC ChangeLog 4108 SHA256 9642be080c217aaaf5397c64a84eddd33af6a38783f48c46c99f6fcfb8755d6e SHA512 32bb71df0a1940e8602c4ae93c76a80b7b5a9cf3b786935be453a1ec115793433b45372fd696f0228452b7760552ab6a700ffc07be53ff7fc36e2e91e97768d0 WHIRLPOOL 85c8725ac70cf7d8848f462bf0c28e55fe171ba1ee4920f80be7e8300e5858a42259eda7fe578f22254ff9f9f7f705498234564c3510df5a4d6ca5bca7e63905
+MISC ChangeLog-2015 17860 SHA256 385812077fe6a13c347c8baf0dbcb991f14049c35f8d7b1e813a65d5c8df5a67 SHA512 1d8b51cbfdba67d4266cddb215490ac54c62361d61ac48e350472a67c37d6c00ee0ea8a594be0c43c18ed986162f256bba77b0f3112127506cb0f2c78a059d81 WHIRLPOOL e527c9bd5dbef09915c82487828f7e2321222c3aa0ca20200b4c9b480507769d9faeed7d7d2ee0b515f9839225f5d83d08b560b205ff5629d29892b37783a221
+MISC metadata.xml 778 SHA256 e0533a86039e784b8b9c9106d848818abe7a352c8285337701c3bafcbfe9c92b SHA512 daef37adb619d49abcb70482f581cbf3492f7fc352f0414f5da2f77ca114b45816fd20466e70028030de3f478ca2ebfb2ff576cb231f860be09e5918931860a8 WHIRLPOOL de8db3bf7b2ad6f6521a743d9bf8b2fefdcbb6219518c7fa9d6e2213ac5e8c380d6944ff24259b41654ccd3f9fcde2bebf66ba22842cc2aa59def75a4a6e8b43
diff --git a/sci-libs/itpp/itpp-4.3.1-r1.ebuild b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..dab233c0d4cd
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.3.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ >=sci-libs/fftw-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+DOCS=(ChangeLog NEWS AUTHORS README)
+
+src_prepare() {
+ # gentoo redefines the CMAKE_BUILD_TYPE
+ sed -i \
+ -e 's/CMAKE_BUILD_TYPE STREQUAL Release/NOT CMAKE_BUILD_TYPE STREQUAL Debug/' \
+ CMakeLists.txt || die
+ # respect gentoo doc dir
+ sed -i \
+ -e "s:share/doc/itpp:share/doc/${PF}:" \
+ itpp/CMakeLists.txt || die
+
+ # respect gentoo libdir
+ sed -i "s#/lib#/$(get_libdir)#" itpp-config.cmake.in
+ sed -i "s#/lib#/$(get_libdir)#" itpp.pc.cmake.in
+ sed -i \
+ -e "s#LIBRARY DESTINATION lib#LIBRARY DESTINATION $(get_libdir)#" \
+ -e "s#ARCHIVE DESTINATION lib#ARCHIVE DESTINATION $(get_libdir)#" \
+ itpp/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLA_VENDOR=Generic
+ $(cmake-utils_use doc HTML_DOCS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/itpp/metadata.xml b/sci-libs/itpp/metadata.xml
new file mode 100644
index 000000000000..6606a6014ad7
--- /dev/null
+++ b/sci-libs/itpp/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ IT++ is a C++ library of mathematical, signal processing and
+ communication classes and functions. Its main use is in simulation
+ of communication systems and for performing research in the area of
+ communications. The kernel of the library consists of generic vector
+ and matrix classes, and a set of accompanying routines. Such a
+ kernel makes IT++ similar to MATLAB or GNU Octave .
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">itpp</remote-id>
+ </upstream>
+</pkgmetadata>