summaryrefslogtreecommitdiff
path: root/sci-libs/ipopt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /sci-libs/ipopt
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'sci-libs/ipopt')
-rw-r--r--sci-libs/ipopt/Manifest2
-rw-r--r--sci-libs/ipopt/ipopt-3.12.12.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/sci-libs/ipopt/Manifest b/sci-libs/ipopt/Manifest
index 4e4fd43019b9..39a89f5f02c1 100644
--- a/sci-libs/ipopt/Manifest
+++ b/sci-libs/ipopt/Manifest
@@ -1,5 +1,7 @@
DIST Ipopt-3.11.7.tgz 4749511 BLAKE2B c344634e427a6603544e50d661cafcf6004b4192a3912453dee96cfa143ca5f290f0efc39f46e983dcba6fe5b8a0becb2fa75bd6cc6f27be5c8ea8dc05f1ec4c SHA512 a9edd33b59c9744dc4e09d709519be1fc3d014cc4f50254402784aa8035d21617323f2879c430245886f2a13165cc81d26779331dc1601f0edfc406953dca56f
DIST Ipopt-3.11.8.tgz 4749758 BLAKE2B c5ee5d3f01f1e8b4b6a1cd7606e2ad1a24c09fb0a8d8ed93fda7af61d543ac4f4579d7bb8817607d916223d9214693e1156f908cef1233a75df8759a1099b5d2 SHA512 1f60ea769dd7305348af3a5d4ed56938f04e59c36fb7a3fa0b808e4788dccee4711f82c3767e2aae87d21618d2a840d0bb22491c21c40bc2f9ebdf4b3a01aeec
+DIST Ipopt-3.12.12.tgz 4530034 BLAKE2B 8a8e24e4e5d8ad5bc1fcfa2de525e1e39c88a4c6dd77b51c0549249f517b3d6a1279e355a7cb606ebd8e606551031b653b78cd4d1cb51dd369e051ffa010011f SHA512 c543695feaa39a69b01e0025ebcd8a8772deb369ea1072f17da4ba34c1b522d322959067f3a6cfc40446e00c2e6dd2d6704a55623aba5d61dff44333727368cb
EBUILD ipopt-3.11.7.ebuild 2396 BLAKE2B 6ee3cafa3373c403bcd6994bc3c42b35015d4d037db8dc1b68c76af950f319d6c09afb0f15862b0e4bbb8ba8f7193dde4135bd08a633f5d68fd73e51bcaccdea SHA512 6a56ea64340b458b928e6024388b9df26ce8ee881d2dff77e5db4840d16391e1239768b4e18be35bdd911b227615df85b372161a45adc63c14c4ceac8344e593
EBUILD ipopt-3.11.8.ebuild 2403 BLAKE2B b67624c94f8a07d2b3caf61687aca289036a3a34e84d5d7799d858aea8e71909ab9ad2a4cba129d92f2230ffbb775c7690a4306fd12d3cff3edccb2bbd7dae91 SHA512 19515a32ac7745199237f185a7bb84155e538be4e9effbd6b01a7571e289d09290215c43b56a12fda9cb43ed69d5a67a8c38815ab66b571be9b99392eadaa5e7
+EBUILD ipopt-3.12.12.ebuild 2080 BLAKE2B 2c3fa37450613d141645906d21c5776064bb6bd6a862014000f99862c7bad432387f43b25dce44667e71ec19fbe0d52a9995ce86c374222510b55bc8c69bbf48 SHA512 52656a3149d8f7582cdd5157faea9c034fc27d436abb5b5de7859361310daebe461c560c9efab87a9cef9abca36247e0db322a828d482c3a63cf822d16f683d3
MISC metadata.xml 842 BLAKE2B 62d2240cf8ca06d45d88c1563473f40bb3e7a9127c76f0bc8fa40b4e3eeddc92387d4112b4e59e03e06757375e8cee6f209ceb72c85bc9903b239e429ce8717f SHA512 6e18c52fa233ba8c19d3493ceda613b39e310fc32976f289a5f1c9709dac860a0e482390ad601019ea1d9818e5e3499887974466803d8c5800e96e9b0d6c0a72
diff --git a/sci-libs/ipopt/ipopt-3.12.12.ebuild b/sci-libs/ipopt/ipopt-3.12.12.ebuild
new file mode 100644
index 000000000000..7aba7e67254c
--- /dev/null
+++ b/sci-libs/ipopt/ipopt-3.12.12.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_NEEDED="mumps"
+
+inherit autotools fortran-2 toolchain-funcs
+
+MY_PN=${PN^}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Interior-Point Optimizer for large-scale nonlinear optimization"
+HOMEPAGE="https://projects.coin-or.org/Ipopt/"
+SRC_URI="http://www.coin-or.org/download/source/${MY_PN}/${MY_P}.tgz"
+
+LICENSE="EPL-1.0 hsl? ( HSL )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hsl lapack mpi mumps static-libs test"
+RESTRICT="test" # Fails to compile
+
+RDEPEND="
+ virtual/blas
+ hsl? ( sci-libs/coinhsl:0= )
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi )
+ mumps? ( sci-libs/mumps:0=[mpi=] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample sci-libs/mumps )"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${MY_PN}"
+
+src_prepare() {
+ if use mpi ; then
+ export CXX=mpicxx FC=mpif77 F77=mpif77 CC=mpicc
+ fi
+ default
+}
+
+src_configure() {
+ # needed for --with-coin-instdir
+ dodir /usr
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-blas-lib="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-coin-instdir="${ED%/}"/usr
+ $(use_with doc dot)
+ )
+
+ if use lapack; then
+ myeconfargs+=( --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" )
+ else
+ myeconfargs+=( --without-lapack )
+ fi
+ if use mumps; then
+ myeconfargs+=(
+ --with-mumps-incdir="${EPREFIX}"/usr/include$(usex mpi '' '/mpiseq')
+ --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps" )
+ else
+ myeconfargs+=( --without-mumps )
+ fi
+ if use hsl; then
+ myeconfargs+=(
+ --with-hsl-incdir="${EPREFIX}"/usr/include
+ --with-hsl-lib="$($(tc-getPKG_CONFIG) --libs coinhsl)" )
+ else
+ myeconfargs+=( --without-hsl )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all
+ use doc && emake doxydoc
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ local HTML_DOCS DOCS
+ use doc && HTML_DOCS=("${S}/doxydoc/html/.")
+ use examples && DOCS+=( examples )
+ einstalldocs
+
+ rm -r "${ED%/}"/usr/share/coin || die
+}