summaryrefslogtreecommitdiff
path: root/sci-libs/iml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /sci-libs/iml
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'sci-libs/iml')
-rw-r--r--sci-libs/iml/Manifest4
-rw-r--r--sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch22
-rw-r--r--sci-libs/iml/iml-1.0.5.ebuild38
-rw-r--r--sci-libs/iml/metadata.xml9
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/iml/Manifest b/sci-libs/iml/Manifest
new file mode 100644
index 000000000000..e9dcaebdb8e6
--- /dev/null
+++ b/sci-libs/iml/Manifest
@@ -0,0 +1,4 @@
+AUX iml-1.0.4-use-any-cblas-implementation.patch 865 BLAKE2B 5167ab1a5f82e5fce596dd3f7cdb3a711f0fd5c86fefc6a36574bcbc63e464115895e43d81eba3d4d04bd016266817440098eed18fab04b30bc45dee37497ffd SHA512 36181f90032b6f4d786d50b327cb342d5c8f4431dd556e4267e99b02e92161adbb9c23d7815e1764d8f237b1f008b2abebc27bdc422ba7296144999f0cde3c19
+DIST iml-1.0.5.tar.bz2 391757 BLAKE2B 5895b353269ce19e17e2522f78eb705c89a47ed3c6cce54d1b7ab3003f59d0a13050b30ce9cedbf38392c737c169740b6c2433f1a74856b0f9d4e6e007ebf804 SHA512 b5a85982636035cc50acba7dcff5478c6271be3669313f01915b2761302d4c77617c0dd7932daf74433098670d3ffdb2ef19eb24450b40709750a0b7c8f797f1
+EBUILD iml-1.0.5.ebuild 713 BLAKE2B 1bc188017da5870454c3c2af732322abac825d2920929110352ce23f7824e59d742efd42d92cab683410f2bde44f76c1324f645ddf99bb5eb1f6536dc7df7492 SHA512 794f836b7f892034aeff8fc69be433cde98ab1e8aa1733faee2bf37cd724797e35bfa96dcb921674df72ed0dd2973f37af6c0fbf0be7109681efce34d58b4ba2
+MISC metadata.xml 434 BLAKE2B 91cfe59fd89e32d7dda5fbb31ecccc46762c6e00cd8de2cbaa8509829d22d1e03f58eb143d72cd9a0c0294a5692643a372c810ecaaaa6d07b61a2818eb10ff91 SHA512 9d2059a19a31ac1393cb69aa28af0cabf1a6da3ee75f7edfea880b506dc8ff764be013e99b4b82fd8819c1552fde80caf15f5f022a0272701800482c2bd81006
diff --git a/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch b/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch
new file mode 100644
index 000000000000..28d70bf91663
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch
@@ -0,0 +1,22 @@
+Patch to detect ATLAS or cblas. Ported from 1.0.3 to 1.0.4.
+
+Patch by Marius Brehler.
+--- a/configure.ac
++++ b/configure.ac
+@@ -76,15 +76,7 @@ location with the options --with-gmp-inc
+ respectively when running configure.
+ )])
+
+-IML_CHECK_CBLAS(,,[AC_MSG_WARN(
+-CBLAS not found!
+-Please make sure that --with-cblas=<linker flags> and optional --with-cblas-include=<path> and --with-cblas-lib=<path> are correctly set.
+-Trying legacy ATLAS configuration.)
+-IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
+-ATLAS not found!
+-ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.)
+-])
+-])
++PKG_CHECK_MODULES([ATLAS], [cblas])
+
+ AC_SUBST(LIBIML_LDFLAGS)
+ AC_SUBST(LDFLAGS)
diff --git a/sci-libs/iml/iml-1.0.5.ebuild b/sci-libs/iml/iml-1.0.5.ebuild
new file mode 100644
index 000000000000..25907543c005
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.4-use-any-cblas-implementation.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-default="${EPREFIX}"/usr \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
diff --git a/sci-libs/iml/metadata.xml b/sci-libs/iml/metadata.xml
new file mode 100644
index 000000000000..673326db1e86
--- /dev/null
+++ b/sci-libs/iml/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>a free library of C source code which implements algorithms for computing exact solutions to dense systems of linear equations over the integers</longdescription>
+</pkgmetadata>