summaryrefslogtreecommitdiff
path: root/sci-libs/ignition-math/ignition-math-6.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sci-libs/ignition-math/ignition-math-6.5.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sci-libs/ignition-math/ignition-math-6.5.0.ebuild')
-rw-r--r--sci-libs/ignition-math/ignition-math-6.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/ignition-math/ignition-math-6.5.0.ebuild b/sci-libs/ignition-math/ignition-math-6.5.0.ebuild
new file mode 100644
index 000000000000..ab724f9e7b7c
--- /dev/null
+++ b/sci-libs/ignition-math/ignition-math-6.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+inherit cmake vcs-snapshot
+
+DESCRIPTION="A small, fast, and high performance math library for robot applications"
+HOMEPAGE="https://ignitionrobotics.org/libraries/math"
+SRC_URI="https://github.com/ignitionrobotics/ign-math/archive/${PN}6_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="6/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-util/ignition-cmake:2"
+BDEPEND="
+ dev-util/ignition-cmake:2"
+
+S="${WORKDIR}/${PN}6_${PV}"
+PATCHES=( "${FILESDIR}/includes.patch" )