summaryrefslogtreecommitdiff
path: root/sci-libs/htslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /sci-libs/htslib
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/Manifest2
-rw-r--r--sci-libs/htslib/htslib-1.9.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index 4c8cfa8cc490..7616be52568a 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1,3 +1,5 @@
DIST htslib-1.5.tar.bz2 1051132 BLAKE2B 90c6aeeaa2a2692228aa1f530d775a6e81f9275d321e8b2d6005b86b9a25e5967acca19dd898311a5bc4f3c17d4e8ea36d18da4602e18fadee47666350122077 SHA512 fd58552ddbd178f9797123fdaf47914ccd0e2aefd055fc6557ac8f479c600775616107cfa871c3acd93079f45974a19f443941a79f2acfd2a8c2983ef35b8917
+DIST htslib-1.9.tar.bz2 1178859 BLAKE2B a0229313d3572717101f4f23d39fa124f3bb38d8b2e65055f4f801dbb5f1549df95115e8beadd8fa024171b3ff8a874d20087bf71819c36700666f168dbe41ab SHA512 ddb0e2d970e4c2c27e203b064898f95cb7c187cd497c02fc7b4312dcea25669d0b6063d537687521e7a065f6daefa1ae897add2df4981037a187b499d08fdef7
EBUILD htslib-1.5.ebuild 769 BLAKE2B 0a40bc1059beabd9671df35ea8febf7b5a11c8b46aa0f66891879962698789b36326fd91423200312497b2f9691766c1dc8aae5dceab5626a7e8de119881793a SHA512 e5df03c2dfa5088743674af125f7464a6e2add8d9c092060d7ddfc914cac4cff16d65eabb35ca3c199290461b92f7424a4347fded4f76dce763801b2b70f91c2
+EBUILD htslib-1.9.ebuild 945 BLAKE2B c198b14431fb321dd125fc344bdccd328b5d1943f08e5d691ad4343fba78637424f12a75498099ccf99aa46df479499ec528f2de737a7d9af668030593c6e860 SHA512 8d7d48327fea34bcb022b4b9ca28eb90fc019c50a4095ae7fbf4ea4ee5fdf1ae0f1f85996d250fd0f26862f1e18d5ea0377f02cdbb9906fa4d2f623d3f8ef36b
MISC metadata.xml 349 BLAKE2B 0a67c5034cea0b990b01f90cf319622a73d2c8c23b89d207f013f1ac27fbfd2f267f4d0a8d331b9ab9de792cea9914671cfb2568a56fc09aeec890f69934e943 SHA512 9108691a0c4c68ececa5e93d1719b4a6fc42c423c0b7dca3c037007873a40c86a44610c54139c6868391bb903d509b0202a87640d7114815d07ef62e478ffce7
diff --git a/sci-libs/htslib/htslib-1.9.ebuild b/sci-libs/htslib/htslib-1.9.ebuild
new file mode 100644
index 000000000000..69df48a332f2
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+SLOT="0/2"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma static-libs"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2:= )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed 's/private_LIBS=$LDFLAGS/private_LIBS=""/g' -i configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+}