summaryrefslogtreecommitdiff
path: root/sci-libs/hipFFT/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-libs/hipFFT/files
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-libs/hipFFT/files')
-rw-r--r--sci-libs/hipFFT/files/hipFFT-4.3.0-add-complex-header.patch11
-rw-r--r--sci-libs/hipFFT/files/hipFFT-4.3.0-gentoo-install-locations.patch42
-rw-r--r--sci-libs/hipFFT/files/hipFFT-4.3.0-remove-git-dependency.patch33
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/hipFFT/files/hipFFT-4.3.0-add-complex-header.patch b/sci-libs/hipFFT/files/hipFFT-4.3.0-add-complex-header.patch
new file mode 100644
index 000000000000..200481788b95
--- /dev/null
+++ b/sci-libs/hipFFT/files/hipFFT-4.3.0-add-complex-header.patch
@@ -0,0 +1,11 @@
+diff --color -uprN orig/clients/rider/rider.cpp hipFFT-rocm-4.3.0/clients/rider/rider.cpp
+--- orig/clients/rider/rider.cpp 2021-08-26 15:05:32.267279103 +0800
++++ hipFFT-rocm-4.3.0/clients/rider/rider.cpp 2021-08-26 15:05:48.795279212 +0800
+@@ -22,6 +22,7 @@
+ #include <cstddef>
+ #include <iostream>
+ #include <numeric>
++#include <complex>
+ #include <random>
+ #include <sstream>
+
diff --git a/sci-libs/hipFFT/files/hipFFT-4.3.0-gentoo-install-locations.patch b/sci-libs/hipFFT/files/hipFFT-4.3.0-gentoo-install-locations.patch
new file mode 100644
index 000000000000..891774eb5a47
--- /dev/null
+++ b/sci-libs/hipFFT/files/hipFFT-4.3.0-gentoo-install-locations.patch
@@ -0,0 +1,42 @@
+diff --color -uprN orig/CMakeLists.txt hipFFT-rocm-4.3.0/CMakeLists.txt
+--- orig/CMakeLists.txt 2021-08-26 14:38:31.051268348 +0800
++++ hipFFT-rocm-4.3.0/CMakeLists.txt 2021-08-26 14:38:42.655268425 +0800
+@@ -143,7 +143,7 @@ endif( )
+ add_subdirectory( library )
+
+ # force library install path to lib (CentOS 7 defaults to lib64)
+-set(CMAKE_INSTALL_LIBDIR "lib" CACHE INTERNAL "Installation directory for libraries" FORCE)
++set(CMAKE_INSTALL_LIBDIR "lib64" CACHE INTERNAL "Installation directory for libraries" FORCE)
+
+ # Build clients of the library
+ if( BUILD_CLIENTS )
+diff --color -uprN orig/library/CMakeLists.txt hipFFT-rocm-4.3.0/library/CMakeLists.txt
+--- orig/library/CMakeLists.txt 2021-08-26 14:38:31.051268348 +0800
++++ hipFFT-rocm-4.3.0/library/CMakeLists.txt 2021-08-26 14:39:21.919268686 +0800
+@@ -77,7 +77,7 @@ target_include_directories(hipfft
+ PUBLIC $<BUILD_INTERFACE:${CMAKE_SOURCE_DIR}/library/include>
+ $<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/include>
+ $<BUILD_INTERFACE:${HIP_INCLUDE_DIRS}>
+- $<INSTALL_INTERFACE:include>
++ $<INSTALL_INTERFACE:include/hipfft>
+ )
+
+ if(BUILD_WITH_LIB STREQUAL "CUDA")
+@@ -112,13 +112,13 @@ if( ROCM_FOUND )
+ rocm_install_targets( TARGETS hipfft
+ INCLUDE
+ ${CMAKE_SOURCE_DIR}/library/include
+- ${CMAKE_BINARY_DIR}/include
+- PREFIX hipfft )
++ ${CMAKE_BINARY_DIR}/include )
++ #PREFIX hipfft )
+ rocm_export_targets( TARGETS hip::hipfft
+- PREFIX hipfft
++ #PREFIX hipfft
+ DEPENDS PACKAGE hip
+ NAMESPACE hip:: )
+- rocm_install_symlink_subdir( hipfft )
++ #rocm_install_symlink_subdir( hipfft )
+
+
+ # During transition to standalone hipFFT repository, don't install
diff --git a/sci-libs/hipFFT/files/hipFFT-4.3.0-remove-git-dependency.patch b/sci-libs/hipFFT/files/hipFFT-4.3.0-remove-git-dependency.patch
new file mode 100644
index 000000000000..563da3085ab9
--- /dev/null
+++ b/sci-libs/hipFFT/files/hipFFT-4.3.0-remove-git-dependency.patch
@@ -0,0 +1,33 @@
+diff --color -uprN orig/cmake/dependencies.cmake hipFFT-rocm-4.3.0/cmake/dependencies.cmake
+--- orig/cmake/dependencies.cmake 2021-08-26 14:48:57.867272506 +0800
++++ hipFFT-rocm-4.3.0/cmake/dependencies.cmake 2021-08-26 14:51:02.571273334 +0800
+@@ -21,9 +21,6 @@
+ #
+ # #############################################################################
+
+-# Git
+-find_package(Git REQUIRED)
+-
+ # HIP
+ if(NOT BUILD_WITH_LIB STREQUAL "CUDA")
+ find_package(hip REQUIRED)
+diff --color -uprN orig/CMakeLists.txt hipFFT-rocm-4.3.0/CMakeLists.txt
+--- orig/CMakeLists.txt 2021-08-26 14:48:57.867272506 +0800
++++ hipFFT-rocm-4.3.0/CMakeLists.txt 2021-08-26 14:49:15.247272622 +0800
+@@ -117,16 +117,6 @@ message(STATUS "BUILD_WITH_COMPILER = "
+ include(cmake/dependencies.cmake)
+
+ if( BUILD_CLIENTS_TESTS )
+- if( GIT_FOUND AND EXISTS "${PROJECT_SOURCE_DIR}/.git" )
+- message(STATUS "rocFFT submodule update")
+- execute_process(COMMAND ${GIT_EXECUTABLE} submodule update --init --recursive
+- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+- RESULT_VARIABLE GIT_SUBMOD_RESULT)
+- if( NOT GIT_SUBMOD_RESULT EQUAL "0" )
+- message(FATAL_ERROR "git submodule update --init --recursive failed with ${GIT_SUBMOD_RESULT}, please checkout submodules manually.")
+- endif( )
+- endif( )
+-
+ if( NOT EXISTS "${PROJECT_SOURCE_DIR}/rocFFT/CMakeLists.txt" )
+ message(FATAL_ERROR "The rocFFT submodule is not present! Please update git submodules and try again.")
+ endif( )