summaryrefslogtreecommitdiff
path: root/sci-libs/hipBLAS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sci-libs/hipBLAS
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sci-libs/hipBLAS')
-rw-r--r--sci-libs/hipBLAS/Manifest3
-rw-r--r--sci-libs/hipBLAS/hipBLAS-4.3.0.ebuild42
-rw-r--r--sci-libs/hipBLAS/metadata.xml15
3 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/hipBLAS/Manifest b/sci-libs/hipBLAS/Manifest
new file mode 100644
index 000000000000..188e2b76fa0d
--- /dev/null
+++ b/sci-libs/hipBLAS/Manifest
@@ -0,0 +1,3 @@
+DIST hipBLAS-4.3.0.tar.gz 428016 BLAKE2B 5a86f7a59aaed9cd6219779546135080f4c583a010f47b902f25545046c50451cd48e570b58c9c3721d735f3ab54295d5eddc61fecc01236e960e37fc87761c8 SHA512 128ee56d6db3d19c83b20fbc315eae8de6ee52aae6c2c5727351bab76c14d9131318cd49a6bcc724f5ec73485783058618bca4dddf96b05cd2f3a772c04f469f
+EBUILD hipBLAS-4.3.0.ebuild 1228 BLAKE2B 355932b9971cf1fae37396989f40657877ab6b01ce4d57ad9fc18017fb01d495ade4c4c444eba6d5567529eeebe534a0930220a828dc6c81aa34c83eb0c2df0e SHA512 bd8d554d4bea3860849622b7c0ee29eb8f6d17d75f01957b07cecead00341fecd5bfcaeafb13062e0e7e45c0a2e552c4ae344197896cc7b9bae032c4db04b2e0
+MISC metadata.xml 453 BLAKE2B 4c1e76cbc277e93a92a95cda405973cc72863882ab9a6729a07976e7815119e985688387c14fc5017fd6e85aaa64eaa72b900375c7f7428eb6bbb2569c5ecaa6 SHA512 0e42066a5ac8720d1b561bcf23269013d9cceff52a9ddd6a6e0af58c7d2628c335bb290e0dc6c262a0542e286f54fd07cb487dd908343fac5cfca07410df6e56
diff --git a/sci-libs/hipBLAS/hipBLAS-4.3.0.ebuild b/sci-libs/hipBLAS/hipBLAS-4.3.0.ebuild
new file mode 100644
index 000000000000..b9ec322edf25
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipBLAS"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-util/hip:${SLOT}
+ sci-libs/rocBLAS:${SLOT}
+ sci-libs/rocSOLVER:${SLOT}"
+DEPEND="${RDPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+src_prepare() {
+ sed -e "s:<INSTALL_INTERFACE\:include:<INSTALL_INTERFACE\:include/hipblas/:" -i library/src/CMakeLists.txt || die
+ sed -e "/PREFIX hipblas/d" -i library/src/CMakeLists.txt || die
+ sed -e "/rocm_install_symlink_subdir( hipblas )/d" -i library/src/CMakeLists.txt || die
+ sed -e "s:hipblas/include:include/hipblas:" -i library/src/CMakeLists.txt || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_CLIENTS_TESTS=OFF # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/hipBLAS/metadata.xml b/sci-libs/hipBLAS/metadata.xml
new file mode 100644
index 000000000000..e74d41fd607c
--- /dev/null
+++ b/sci-libs/hipBLAS/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>xgreenlandforwyy@gmail.com</email>
+ <name>Yiyang Wu</name>
+ </maintainer>
+</pkgmetadata>