summaryrefslogtreecommitdiff
path: root/sci-libs/hipBLAS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
commitd5c5aa9b48bd6a821f5e0a1a98474ac35fb21360 (patch)
tree9de3699cbe327fb5dd93a6ec37b895f9fdb94494 /sci-libs/hipBLAS
parentc6a12f3c8604a9269cfb82d666fc716df0e67792 (diff)
gentoo auto-resync : 29:07:2023 - 04:38:40
Diffstat (limited to 'sci-libs/hipBLAS')
-rw-r--r--sci-libs/hipBLAS/Manifest2
-rw-r--r--sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/hipBLAS/Manifest b/sci-libs/hipBLAS/Manifest
index 4435a88807d0..e9cc8e337e11 100644
--- a/sci-libs/hipBLAS/Manifest
+++ b/sci-libs/hipBLAS/Manifest
@@ -1,3 +1,5 @@
DIST hipBLAS-5.1.3.tar.gz 526704 BLAKE2B d32d7029ea910c341e00dccab1ee9ab984518368cf38524f2264bb808cc1242b3d57db283937650f54460cb01174ec90f02c4bd66866cba4be5d0a1855814f0e SHA512 41dbc86b7ea53e7c0f1d629130f90b719f864ceddae972f1c68911e97b6233286f0c22c0fcfce049ae7db73a1ed41bdaf730040c72f1790fca367362c14ac707
+DIST hipBLAS-5.4.2.tar.gz 930814 BLAKE2B 702df09010b50652feb8f7e5741b27117aa58fc3e3b1b5f89f5043073a47581d1710f0831740453e84f7594b1b305e95d2681709898e5231c3eee2e8207404a3 SHA512 a941350d2d25022cf5142f68559242a048136bdd048dafcd544a0241cf3b510062273163f7a0eecc55f17ec47a1063d84d6102ca766ba7cde9b704eee5c44cd8
EBUILD hipBLAS-5.1.3.ebuild 1290 BLAKE2B 2d5722359ad1192d245a0d344aa2d3ab794f49be3cf7d6e0e90936d8813c29e7d2b96fb571f0b34aa5cf2883186bf20c5a4e8d974bba148ac20370b032176d1d SHA512 a95a0f8ae694e346aa00d4de3b09938515e8f104e731fa14936dd6f335996c32136d043f326887b8bcde718b5782cb464fc9a23641ea9641492fa21efee4b3a3
+EBUILD hipBLAS-5.4.2.ebuild 929 BLAKE2B ce433ff82d693d8b446bc47ce93e7ded4a4401cb423d45cbe9040d5a6b19bd1daa1b0b62e227c69505f941778fd3832827e867894f1ddb92538aebedddc26f67 SHA512 09813a2e0878222efdee2a5e87401671337dedb76441bbc5cca3c42f2aea3e88281ac503feb93b5ec3d4a904ceebe34bb9344ac577b9fdedb9f65e6678ead8fa
MISC metadata.xml 453 BLAKE2B 4c1e76cbc277e93a92a95cda405973cc72863882ab9a6729a07976e7815119e985688387c14fc5017fd6e85aaa64eaa72b900375c7f7428eb6bbb2569c5ecaa6 SHA512 0e42066a5ac8720d1b561bcf23269013d9cceff52a9ddd6a6e0af58c7d2628c335bb290e0dc6c262a0542e286f54fd07cb487dd908343fac5cfca07410df6e56
diff --git a/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild b/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
new file mode 100644
index 000000000000..b61f8865b925
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipBLAS"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocBLAS:${SLOT}[${ROCM_USEDEP}]
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CLIENTS_TESTS=OFF # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}