summaryrefslogtreecommitdiff
path: root/sci-libs/hdf5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /sci-libs/hdf5
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/Manifest3
-rw-r--r--sci-libs/hdf5/hdf5-1.12.1-r1.ebuild123
-rw-r--r--sci-libs/hdf5/metadata.xml11
3 files changed, 131 insertions, 6 deletions
diff --git a/sci-libs/hdf5/Manifest b/sci-libs/hdf5/Manifest
index c74989cec2cb..0f4a7f6a7ab2 100644
--- a/sci-libs/hdf5/Manifest
+++ b/sci-libs/hdf5/Manifest
@@ -6,5 +6,6 @@ DIST hdf5-1.10.5.tar.bz2 8706317 BLAKE2B ac326be8fe4ccc4b0153f15bc7d65aa8f1adc2a
DIST hdf5-1.12.1.tar.bz2 9724309 BLAKE2B cc75ba497188b33972218d02a7601acad1a0443bdb934ecd1641ef5996076fe120e3b72dba3a99d99f919fb4e478d1e531414448de9a7b97a0afde58a4c7c23f SHA512 158a067ee284ccb9e2c4db12e9d37cf187d90d9ef1bed7a6303e2c3a2fd216d7b13a46c5f46018b097511281c4246156b6f917633ca88872f10f0ad04be285fd
EBUILD hdf5-1.10.5-r1.ebuild 2883 BLAKE2B ddfc519217494eb2f3a2cd2a37f70d9e2005cd049299fbaf2386414db0eac65a2655b39fba85231896cd2f2ef42fd15d57273b77fa53e0d492a889fc6db51fbe SHA512 007a97a089002e330569913ce42afd92b63d659b9d9f4fabe85170d7633950da025cfc55273f564faf1aec52d3ad4c704825cc501bd441d522f65238ff44ad88
EBUILD hdf5-1.10.5.ebuild 2712 BLAKE2B 56dc60e54a2e3758b32eba9977bb96e67bcdec38670579e985733ecede749f638370bee98959986a76e841c8adf4a92740fae6b8c8ed36e5e0ba2814a2f82537 SHA512 ebf92105b2d149f1947dd0d95b2ef5da85b4d57a51eeb4e5c8d9535e706b06e6c46910ee8671f1d44021636cec71070755aa7d7e62db4f9e1fb39d7e0d7d4fbd
+EBUILD hdf5-1.12.1-r1.ebuild 3158 BLAKE2B 7017b7915fe0b3d489ff261ef54ab8e01cf33a0709a7105272607e84b3347ab469605e3629f874e3f96667c1adce0891901213156ad8e4b8169193787d250941 SHA512 33072c3b6efd4c9d83167961e7a038e0c218be8c1ca66d497751b4b3e8b204422d49223092ef4019db8e2c57f6c0f46db72cdc71398163b46136775317ed89d9
EBUILD hdf5-1.12.1.ebuild 3061 BLAKE2B a21c786534715cbfdb57208a021c6f48ff89417db20490673bb86c362b7065280f810135a6b60ca20d6cbb6a7bcc6f332f64cada97ca8fe25a52bf9e868f905a SHA512 0f809656f7088844eaeca31695877919cf3aae466bf93e1b3c9bd72474712415dca62f39bc51c6e2265c2f64427a5c1274fbb18092d614ee32c0f29d6068c0c9
-MISC metadata.xml 764 BLAKE2B a3941269717b30a23dd89de26068813dac6d6bd9cf3f5d30a22f4f44bae0eaccc1188041020af175f8e2bf7104d4b3ae312ba5a3fee4873416af4643681944da SHA512 40336c962e49ef4c306610de02d0622ff92860338787fdc60e43cbdaa318a18e1073d2c0cd9faefa33dd51d90e9c019dce71fb1c4ec27f42217808379f88aab5
+MISC metadata.xml 935 BLAKE2B b9195ac707556cdb2ee2c4d032fabd88aad674ad4fa52a60fbeb31c47ae51b9511bb097d4271d19b05d1dbc3b59b3cafb3b7d407bd9b8095bfd449fa8728ab6a SHA512 57c4694ea2c024c7babdf34474a61b92165b6c322fa11ec7fefdf16d66b44f91f66d63eeb355311b121fbeec8da810e393e3e785a4c434ff658c7b4bd7baf22b
diff --git a/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild b/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..9a0d092cd1fa
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.12.1-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED="fortran"
+
+inherit cmake flag-o-matic fortran-2
+
+MY_P="${PN}-${PV/_p/-patch}"
+MAJOR_P="${PN}-$(ver_cut 1-2)"
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="https://www.hdfgroup.org/HDF5/"
+SRC_URI="https://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0/${PV%%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx debug doc examples fortran +hl mpi ros3 szip test threads unsupported zlib"
+
+REQUIRED_USE="
+ !unsupported? (
+ mpi? ( !cxx !threads )
+ threads? ( !cxx !fortran !hl )
+ )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ ros3? (
+ net-misc/curl
+ dev-libs/openssl:=
+ )
+ szip? ( virtual/szip )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? (
+ app-doc/doxygen
+ virtual/latex-base
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.1-cmake_installdirs.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ export CC="mpicc"
+ use fortran && export FC="mpif90"
+ append-libs -lmpi
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=OFF
+ -DFETCHCONTENT_FULLY_DISCONNECTED=ON
+ -DHDF5_BUILD_EXAMPLES=OFF
+ -DALLOW_UNSUPPORTED=$(usex unsupported)
+ -DBUILD_TESTING=$(usex test)
+ -DHDF5_BUILD_CPP_LIB=$(usex cxx)
+ -DHDF5_BUILD_DOC=$(usex doc)
+ -DHDF5_BUILD_FORTRAN=$(usex fortran)
+ -DHDF5_BUILD_HL_LIB=$(usex hl)
+ -DHDF5_ENABLE_CODESTACK=$(usex debug)
+ -DHDF5_ENABLE_PARALLEL=$(usex mpi)
+ -DHDF5_ENABLE_SZIP_ENCODING=$(usex szip)
+ -DHDF5_ENABLE_SZIP_SUPPORT=$(usex szip)
+ -DHDF5_ENABLE_THREADSAFE=$(usex threads)
+ -DHDF5_ENABLE_Z_LIB_SUPPORT=$(usex zlib)
+ -DHDF5_ENABLE_ROS3_VFD:BOOL=$(usex ros3)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # TODO: generate functioning example runners from their respective
+ # .in files - as of version 1.12.1 upstream only has it implemented
+ # for autoconf.
+ if use examples; then
+ # These are all useless outside the source tree
+ rm -f {examples,c++/examples,fortran/examples}/{Makefile*,CMake*}
+ rm -f hl/{examples,c++/examples,fortran/examples}/{Makefile*,CMake*}
+
+ dodoc -r examples
+ if use cxx; then
+ docinto c++
+ dodoc -r c++/examples
+ fi
+ if use fortran; then
+ docinto fortran
+ dodoc -r fortran/examples
+ fi
+ if use hl; then
+ docinto hl
+ dodoc -r hl/examples
+ if use cxx; then
+ docinto hl/c++
+ dodoc -r hl/c++/examples
+ fi
+ if use fortran; then
+ docinto hl/fortran
+ dodoc -r hl/fortran/examples
+ fi
+ fi
+ fi
+}
diff --git a/sci-libs/hdf5/metadata.xml b/sci-libs/hdf5/metadata.xml
index ea5ba62b798f..042059bcd497 100644
--- a/sci-libs/hdf5/metadata.xml
+++ b/sci-libs/hdf5/metadata.xml
@@ -6,13 +6,14 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
- HDF5 is a file format and library for storing scientific data. HDF5
- was designed and implemented to address the deficiencies of HDF4.x. It
- has a more powerful and flexible data model, supports files larger
- than 2 GB, and supports parallel I/O.
-</longdescription>
+ HDF5 is a file format and library for storing scientific data. HDF5
+ was designed and implemented to address the deficiencies of HDF4.x. It
+ has a more powerful and flexible data model, supports files larger
+ than 2 GB, and supports parallel I/O.
+ </longdescription>
<use>
<flag name="hl">Enable high level API (https://support.hdfgroup.org/HDF5/doc/HL/index.html)</flag>
+ <flag name="ros3">Enable support for read-only S3 access (https://portal.hdfgroup.org/display/HDF5/Configuration+and+Setup+for+HDF5+Read+Only+S3+VFD)</flag>
<flag name="unsupported">Enable unsupported combinations of configuration options</flag>
</use>
</pkgmetadata>