summaryrefslogtreecommitdiff
path: root/sci-libs/gsl/gsl-2.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-01 04:05:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-01 04:05:50 +0000
commit6438b14169223c6931a87dd4e1e357934b2c0852 (patch)
treec429df63c28f2b4670bc1d0dfc6ea140ed24ceae /sci-libs/gsl/gsl-2.7.1-r1.ebuild
parent5df0c8ba4bb09f65c6cfb7d67dead00d6b2a1bf9 (diff)
gentoo auto-resync : 01:03:2023 - 04:05:50
Diffstat (limited to 'sci-libs/gsl/gsl-2.7.1-r1.ebuild')
-rw-r--r--sci-libs/gsl/gsl-2.7.1-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sci-libs/gsl/gsl-2.7.1-r1.ebuild b/sci-libs/gsl/gsl-2.7.1-r1.ebuild
deleted file mode 100644
index 64e427099641..000000000000
--- a/sci-libs/gsl/gsl-2.7.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="https://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-2.7-cblas.patch.bz2"
-
-LICENSE="GPL-3+"
-# Usually 0/${PV} but check
-SLOT="0/27"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE="cblas-external +deprecated static-libs"
-
-RDEPEND="cblas-external? ( virtual/cblas:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${WORKDIR}"/${PN}-2.7-cblas.patch
-)
-
-src_prepare() {
- filter-flags -ffast-math
-
- default
-
- if use deprecated; then
- sed -i -e "/GSL_DISABLE_DEPRECATED/,+2d" configure.ac || die
- fi
- eautoreconf
-}
-
-src_configure() {
- if use cblas-external; then
- export CBLAS_LIBS="$($(tc-getPKG_CONFIG) --libs cblas)"
- export CBLAS_CFLAGS="$($(tc-getPKG_CONFIG) --cflags cblas)"
- fi
-
- econf \
- --enable-shared \
- $(use_with cblas-external) \
- $(use_enable static-libs static)
-}
-
-src_test() {
- local MAKEOPTS="${MAKEOPTS} -j1"
- default
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}