summaryrefslogtreecommitdiff
path: root/sci-libs/gmsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/gmsh
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/gmsh')
-rw-r--r--sci-libs/gmsh/Manifest3
-rw-r--r--sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch80
-rw-r--r--sci-libs/gmsh/gmsh-4.9.5-r1.ebuild2
3 files changed, 2 insertions, 83 deletions
diff --git a/sci-libs/gmsh/Manifest b/sci-libs/gmsh/Manifest
index 27ef000b49c0..f76e4aff6141 100644
--- a/sci-libs/gmsh/Manifest
+++ b/sci-libs/gmsh/Manifest
@@ -1,4 +1,3 @@
-AUX gmsh-4.8.4-gcc11.patch 2821 BLAKE2B 21977c525d2359cddcc7dd189a8aa5fa74acb9bd9badd9accac7a7e8334311f4f2c007079c5580118e2f991d802af3ce4d54c93a8e9ada76dc5b41279cdfc848 SHA512 fdeced297f2188461d0d61bafdeb4bf0c2663a7d7cda9cc4aa61f4211173243cb7e6ea68f8db15ed45422a4d0914d628231060f6a3f30251765da768975b0f5b
DIST gmsh-4.9.5-source.tgz 14921704 BLAKE2B e805bd786154bf6ce8bebb2d2c38204a88d06a251c45fbe6dd37641a15e02291993c244f26a01faad2a6445a4852274e5481d4236b7a3d9b7ee65fc863f1b880 SHA512 4da61bdf03fb9466af80ac790e83c8888bab755c78d860d601474d7ebca220ac51cba620db310165021412dbecc1cf187ccdff47b8a78e0579339bb72cfa6484
-EBUILD gmsh-4.9.5-r1.ebuild 1842 BLAKE2B 416dc95a9ed6ee4d5331892198ce4fb429e20b8b051c12c879f7597cbc6695751a0e2b0ef3b5f6cb958a9c60530c00bcde8d363120a812ef96c93e69b2c93050 SHA512 47d4b689560a18b99eeebb6cf966012ba14df6436b6b6c6def839a1a0e5c7a787a7aa0880391f5bfae4e84c24b8b2def701a64d55d87be11f8a06b43d052cf76
+EBUILD gmsh-4.9.5-r1.ebuild 1839 BLAKE2B 410b50fbde4f16a87bf96c61a2971b43a8361e066755eefde825767a4766a7d37496a961a340ece6747f84ba50d8c93dd7c7308930782dc4d2931e00ab345c8d SHA512 d7aa4fb98209e3f1f447be4656148faa11c4dca0e0797defc7ca4ec86bde4140fd473d2d0449f1a6df15ee4a8c88ae002b58e16fbda3adbac1ecf1fae3f52bf4
MISC metadata.xml 802 BLAKE2B 5ddd7f70af792e529ca9b5197b80775cea3390fdb04fdc65df5e43333aac0ac3f1d5f2fc16c32c5eb5336f3ec12ad4b2fefd6b055a3f2361f42a2bd77aa83b47 SHA512 08356d610e96e262c6d2b49647835e8dfc96ebb7efa3b9c078f5d930c83eb23211c9b61bd57fdcdbc067d957b47ab0c8c650b15169fa40c3a8da5aab8b325666
diff --git a/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch b/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch
deleted file mode 100644
index 3f16ef476d7f..000000000000
--- a/sci-libs/gmsh/files/gmsh-4.8.4-gcc11.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-https://gitlab.onelab.info/gmsh/gmsh/-/commit/e7cd675083f72c6c01701cb0f16d1639aca121ba
-https://bugs.gentoo.org/800536
-
-From: Tristan Carel <tristan.carel@epfl.ch>
-Date: Wed, 28 Jul 2021 10:55:40 +0200
-Subject: [PATCH] Fix symbol conflict in picojson with GCC 11 internal macro
-
-Build issue on MacOS with GCC 11 from brew:
-```
-/usr/local/Cellar/gcc/11.1.0_1/lib/gcc/11/gcc/x86_64-apple-darwin20/11.1.0/include/serializeintrin.h:37: note: macro "_serialize" defined here
- 37 | #define _serialize() __builtin_ia32_serialize ()
- |
-```
---- a/Common/picojson.h
-+++ b/Common/picojson.h
-@@ -186,8 +186,8 @@ public:
- private:
- template <typename T> value(const T *); // intentionally defined to block implicit conversion of pointer to bool
- template <typename Iter> static void _indent(Iter os, int indent);
-- template <typename Iter> void _serialize(Iter os, int indent) const;
-- std::string _serialize(int indent) const;
-+ template <typename Iter> void serialize_(Iter os, int indent) const;
-+ std::string serialize_(int indent) const;
- void clear();
- };
-
-@@ -549,11 +549,11 @@ template <typename Iter> void serialize_str(const std::string &s, Iter oi) {
- }
-
- template <typename Iter> void value::serialize(Iter oi, bool prettify) const {
-- return _serialize(oi, prettify ? 0 : -1);
-+ return serialize_(oi, prettify ? 0 : -1);
- }
-
- inline std::string value::serialize(bool prettify) const {
-- return _serialize(prettify ? 0 : -1);
-+ return serialize_(prettify ? 0 : -1);
- }
-
- template <typename Iter> void value::_indent(Iter oi, int indent) {
-@@ -563,7 +563,7 @@ template <typename Iter> void value::_indent(Iter oi, int indent) {
- }
- }
-
--template <typename Iter> void value::_serialize(Iter oi, int indent) const {
-+template <typename Iter> void value::serialize_(Iter oi, int indent) const {
- switch (type_) {
- case string_type:
- serialize_str(*u_.string_, oi);
-@@ -580,7 +580,7 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
- if (indent != -1) {
- _indent(oi, indent);
- }
-- i->_serialize(oi, indent);
-+ i->serialize_(oi, indent);
- }
- if (indent != -1) {
- --indent;
-@@ -608,7 +608,7 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
- if (indent != -1) {
- *oi++ = ' ';
- }
-- i->second._serialize(oi, indent);
-+ i->second.serialize_(oi, indent);
- }
- if (indent != -1) {
- --indent;
-@@ -628,9 +628,9 @@ template <typename Iter> void value::_serialize(Iter oi, int indent) const {
- }
- }
-
--inline std::string value::_serialize(int indent) const {
-+inline std::string value::serialize_(int indent) const {
- std::string s;
-- _serialize(std::back_inserter(s), indent);
-+ serialize_(std::back_inserter(s), indent);
- return s;
- }
-
-GitLab
diff --git a/sci-libs/gmsh/gmsh-4.9.5-r1.ebuild b/sci-libs/gmsh/gmsh-4.9.5-r1.ebuild
index af13e7d74515..902c8379230d 100644
--- a/sci-libs/gmsh/gmsh-4.9.5-r1.ebuild
+++ b/sci-libs/gmsh/gmsh-4.9.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake fortran-2 python-any-r1 toolchain-funcs