summaryrefslogtreecommitdiff
path: root/sci-libs/givaro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-libs/givaro
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-libs/givaro')
-rw-r--r--sci-libs/givaro/Manifest3
-rw-r--r--sci-libs/givaro/givaro-4.1.1.ebuild45
-rw-r--r--sci-libs/givaro/metadata.xml24
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/givaro/Manifest b/sci-libs/givaro/Manifest
new file mode 100644
index 000000000000..1f8e873e0c6e
--- /dev/null
+++ b/sci-libs/givaro/Manifest
@@ -0,0 +1,3 @@
+DIST givaro-4.1.1.tar.gz 1008358 BLAKE2B 246fd1a263174f58d96dd66fa79e6113368b6c318c33d68858a339bd9cb778dfda84636c683ee9d02f2ac72ccff8ac22d395b92741448a8ed2ce08c041ac8ba9 SHA512 7ad15ac24f55ad65c9c5d0d48ff4388d0494e75dc7b66d1e139195cd086ff2371259bdb5df940fead1db2fd378bb76289f2327a8d6f41575d99d424a74cf644c
+EBUILD givaro-4.1.1.ebuild 1645 BLAKE2B 671186b7b4e55c72c3bd2a76803bbabd193942c97488be4ad7d89abf3497ff7fd4e9d07d847f40daeb0cc616d62a6153beca530dc1d13cfe74495298920bc8f2 SHA512 47b584f55c716720df959527c1f644922d097f82f5d913772399490e859443c407f3ad6e55e5d24e4ded60541c433fe1fa7424f011acb2bd4028f2aa8088a49f
+MISC metadata.xml 738 BLAKE2B 89916089365fd82a21b273b91b832888d542ec4c0d7533d725f2be0bf9c9310758f3d4ccd5e8c1d6abf8cb63f92e62c048be22f99a88f05eb6db5cd6bc5a8c17 SHA512 768957687398de4ece1f9d04f6f4c7836b0230d166553b5b2998d61875d78810c1470061eeaac5d39b4ee81f839cb4eddc4ba2316a7024374f8a8864a275af4f
diff --git a/sci-libs/givaro/givaro-4.1.1.ebuild b/sci-libs/givaro/givaro-4.1.1.ebuild
new file mode 100644
index 000000000000..68976e9c1941
--- /dev/null
+++ b/sci-libs/givaro/givaro-4.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library for arithmetic and algebraic computations"
+HOMEPAGE="https://casys.gricad-pages.univ-grenoble-alpes.fr/givaro/"
+SRC_URI="https://github.com/linbox-team/givaro/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="CeCILL-B"
+SLOT="0/9"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 doc static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen[dot,latex] )"
+DEPEND="dev-libs/gmp:0[cxx]"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_configure(){
+ # Passing "--disable-doc" also accidentally enables building
+ # the documentation, so we can't just $(use_enable doc) here.
+ # https://github.com/linbox-team/givaro/issues/148
+ econf \
+ $(usex doc --enable-doc "" "" "") \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_fma3 fma) \
+ $(use_enable cpu_flags_x86_fma4 fma4) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_sse4_2 sse42) \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable cpu_flags_x86_avx2 avx2)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/givaro/metadata.xml b/sci-libs/givaro/metadata.xml
new file mode 100644
index 000000000000..e1c0c3cbd9cd
--- /dev/null
+++ b/sci-libs/givaro/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">linbox-team/givaro</remote-id>
+ </upstream>
+</pkgmetadata>