summaryrefslogtreecommitdiff
path: root/sci-libs/givaro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /sci-libs/givaro
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'sci-libs/givaro')
-rw-r--r--sci-libs/givaro/Manifest2
-rw-r--r--sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch36
-rw-r--r--sci-libs/givaro/givaro-4.1.1-r2.ebuild56
3 files changed, 94 insertions, 0 deletions
diff --git a/sci-libs/givaro/Manifest b/sci-libs/givaro/Manifest
index 0e25f8681f93..0b0feb9932b3 100644
--- a/sci-libs/givaro/Manifest
+++ b/sci-libs/givaro/Manifest
@@ -1,3 +1,5 @@
+AUX givaro-4.1.1-gcc-10.patch 1035 BLAKE2B 460371ff8e628e1945a29d9c6d2b718c7d98b07b023540bc49a439cd941a19191db44536a1514495014084a85028debfb4e714d6d9efd9ae7c7c12687d5f8400 SHA512 3e154b3cf6c11a106f78778eeaaf0c2cfe81e25d18f623b5b071b306f1221c8513f27f87ab3e3684a8b3f18138dfbb516c33691dbb854072a35a0be21ac0bc48
DIST givaro-4.1.1.tar.gz 1008358 BLAKE2B 246fd1a263174f58d96dd66fa79e6113368b6c318c33d68858a339bd9cb778dfda84636c683ee9d02f2ac72ccff8ac22d395b92741448a8ed2ce08c041ac8ba9 SHA512 7ad15ac24f55ad65c9c5d0d48ff4388d0494e75dc7b66d1e139195cd086ff2371259bdb5df940fead1db2fd378bb76289f2327a8d6f41575d99d424a74cf644c
EBUILD givaro-4.1.1-r1.ebuild 1797 BLAKE2B 2bc0f4d503d59240a01caa2f4101dbd9fc04e8a0c99ca42befe3f7810e2956816bf1bdbd3eb29ecd5427e41b7893c3172fd3c1de4c67a0b735986eda3cd5300d SHA512 9ba90e4c926b04036effd65e005c8a43cd28e665fd0f97f8cb9f4100bdd3ab8f66ac0ea65e3ea2fba3a3fac877bd7253760c7738716105a680d9987dbe2ee382
+EBUILD givaro-4.1.1-r2.ebuild 1852 BLAKE2B 4769a6d4991897a6d3cbd12879d6930a47cc97e89909d19e35a27db7bcd4e1fc8c8a5877de18ed1e1173affb745e1c14979b04e3b634815cbd9b8fb3cb4f73f8 SHA512 76fae7f9ed7efdc87ce6c0d10349484b97955e9bfdbd4a01f83bb66ae0ad9a732308d61c9b27aef47ed2ff1bc7316c3fe4f920cf88bb0b5252c172027294b316
MISC metadata.xml 768 BLAKE2B fd86b985828a4ff9834fff86884bc89c2d346a8a60971000589668161ff88f493cd6cedce1e7c08db85f948de3c2ae2afde4f27565abbc6da4d652852c54277b SHA512 e79a2f5b28fbd0b8b1eaaa3791ee89441a45fc5d6c2e4c43cc1dd80456d847e3d85c14cfbef27eb2ea4c809513ece2c15f400fe3f3bf293d66461c2b46e99e27
diff --git a/sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch b/sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch
new file mode 100644
index 000000000000..0564c7f94fef
--- /dev/null
+++ b/sci-libs/givaro/files/givaro-4.1.1-gcc-10.patch
@@ -0,0 +1,36 @@
+From 5ba9fa4930b347aea8817da444bea5a88971079a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 7 Aug 2021 11:43:29 -0400
+Subject: [PATCH 1/1] configure: hack out old GCC-4.x test.
+
+The Givaro ./configure script fails to detect modern versions of GCC,
+instead deciding that they must be gcc-4.8. As a result, we wind up
+with "-fabi-version=6" in CXXFLAGS, which then gets propagated to
+users of "givaro-config --cflags", like fflas-ffpack.
+
+This is already fixed upstream, but not in a release, and not in a
+way that I care to backport. Here we just hack the configure script
+directly since the change is so trivial.
+---
+ configure | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/configure b/configure
+index 1eb75b0..f3bbb52 100755
+--- a/configure
++++ b/configure
+@@ -17172,11 +17172,6 @@ fi
+
+ echo "-----------------------------------------------"
+
+-if test "x$CCNAM" = "xgcc48"; then :
+- REQUIRED_FLAGS="${REQUIRED_FLAGS} -fabi-version=6"
+-fi
+-
+-
+
+ # Machine characteristics
+
+--
+2.31.1
+
diff --git a/sci-libs/givaro/givaro-4.1.1-r2.ebuild b/sci-libs/givaro/givaro-4.1.1-r2.ebuild
new file mode 100644
index 000000000000..2e76210dd2e3
--- /dev/null
+++ b/sci-libs/givaro/givaro-4.1.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library for arithmetic and algebraic computations"
+HOMEPAGE="https://casys.gricad-pages.univ-grenoble-alpes.fr/givaro/"
+SRC_URI="https://github.com/linbox-team/givaro/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="CeCILL-B"
+SLOT="0/9"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 doc static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+DEPEND="dev-libs/gmp:0[cxx(+)]"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+PATCHES=( "${FILESDIR}/givaro-4.1.1-gcc-10.patch" )
+
+src_configure() {
+ # Passing "--disable-doc" also accidentally enables building
+ # the documentation, so we can't just $(use_enable doc) here.
+ # https://github.com/linbox-team/givaro/issues/148
+ econf \
+ $(usex doc --enable-doc "" "" "") \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_fma3 fma) \
+ $(use_enable cpu_flags_x86_fma4 fma4) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_sse4_2 sse42) \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable cpu_flags_x86_avx2 avx2)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}