summaryrefslogtreecommitdiff
path: root/sci-libs/ginkgo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sci-libs/ginkgo
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sci-libs/ginkgo')
-rw-r--r--sci-libs/ginkgo/Manifest5
-rw-r--r--sci-libs/ginkgo/files/ginkgo-1.1.1-set_soname.patch14
-rw-r--r--sci-libs/ginkgo/ginkgo-1.1.1-r1.ebuild60
-rw-r--r--sci-libs/ginkgo/ginkgo-9999.ebuild60
-rw-r--r--sci-libs/ginkgo/metadata.xml23
5 files changed, 162 insertions, 0 deletions
diff --git a/sci-libs/ginkgo/Manifest b/sci-libs/ginkgo/Manifest
new file mode 100644
index 000000000000..ae0645747121
--- /dev/null
+++ b/sci-libs/ginkgo/Manifest
@@ -0,0 +1,5 @@
+AUX ginkgo-1.1.1-set_soname.patch 673 BLAKE2B 740cebca34c0eb3472bb5c5b1cd3908701df0acd5b3683d87ed67722912860a3ce298bef181e7bd26defa162ae9374e87cccb0ca5d0df7b1ed296e6bc61b7122 SHA512 294b6855239ffb9bc311cdfbdf49956dba10ec47b6e0d3a48bf3a8e002720bb58d9a03ae5ce68c85552e789818f26913ca3a9d3307c5e68dc86db3a5f1d703d5
+DIST ginkgo-1.1.1.tar.gz 11787690 BLAKE2B 75c2c9b2d1e9ba00e3b0a20859af621cdf4aefe7c6e5ec9c7fc34a5368e5bee70d7d2b86ed9b2d9075ab7cc1a3334434fe20329d780f693be45fd7707cdbe27f SHA512 ab8f2d36453f4e60a4e0a13eddc4a137006c1cc6c9c0db00997dd721dfc06f4401109c5a22ba23a838206cff576d5041d06edaed8823006e69f11e360d1dadce
+EBUILD ginkgo-1.1.1-r1.ebuild 1255 BLAKE2B 435703ad17ca61850b8a7bad01ef0ef763ed09eea57b99349f5af2098527a33a53ff8c4ce1e434c231e487cb31cd2581de002304a01a3783da5a8e22a2a44825 SHA512 c6f1343d676f70b0eec0e137c94273de1ffade68533e7c4022ffba4bfeb0522f8cd02eba8f38edac6b4453190a86f0adccd51239d71d2b18f6e3f54b30acdc76
+EBUILD ginkgo-9999.ebuild 1255 BLAKE2B 435703ad17ca61850b8a7bad01ef0ef763ed09eea57b99349f5af2098527a33a53ff8c4ce1e434c231e487cb31cd2581de002304a01a3783da5a8e22a2a44825 SHA512 c6f1343d676f70b0eec0e137c94273de1ffade68533e7c4022ffba4bfeb0522f8cd02eba8f38edac6b4453190a86f0adccd51239d71d2b18f6e3f54b30acdc76
+MISC metadata.xml 809 BLAKE2B 03a441e0dab912e0e44360d81aaae8a290cdf8b3545850e796df22c211ed433a74cccc535c0ed655dafe741aedc4b272d40617104d4df92c14c8fdab6e63d3ce SHA512 8d21f84fa4e7a4d94056cd09324e223f510ce2100f4b5ab2874280a0012b1b74cf891faf1802bd780c6fb3bd86751fda6598787fa328f5d1fcde0e853889f4f5
diff --git a/sci-libs/ginkgo/files/ginkgo-1.1.1-set_soname.patch b/sci-libs/ginkgo/files/ginkgo-1.1.1-set_soname.patch
new file mode 100644
index 000000000000..9feceee00f7b
--- /dev/null
+++ b/sci-libs/ginkgo/files/ginkgo-1.1.1-set_soname.patch
@@ -0,0 +1,14 @@
+diff --git a/cmake/build_helpers.cmake b/cmake/build_helpers.cmake
+index 8a8ad04..03c6db6 100644
+--- a/cmake/build_helpers.cmake
++++ b/cmake/build_helpers.cmake
+@@ -17,6 +17,9 @@ function(ginkgo_compile_features name)
+ if(GINKGO_WITH_IWYU AND GINKGO_IWYU_PATH)
+ set_property(TARGET "${name}" PROPERTY CXX_INCLUDE_WHAT_YOU_USE ${GINKGO_IWYU_PATH})
+ endif()
++ # Set an appropriate SONAME
++ set_property(TARGET "${name}" PROPERTY
++ SOVERSION "${Ginkgo_VERSION}")
+ if(GINKGO_CHANGED_SHARED_LIBRARY)
+ # Put all shared libraries and corresponding imported libraries into the specified path
+ set_property(TARGET "${name}" PROPERTY
diff --git a/sci-libs/ginkgo/ginkgo-1.1.1-r1.ebuild b/sci-libs/ginkgo/ginkgo-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..5348b9a51be6
--- /dev/null
+++ b/sci-libs/ginkgo/ginkgo-1.1.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical linear algebra software package"
+HOMEPAGE="https://ginkgo-project.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/ginkgo-project/ginkgo"
+ SRC_URI=""
+ KEYWORDS=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+IUSE="+openmp cuda"
+
+RDEPEND="
+ cuda? ( dev-util/nvidia-cuda-sdk )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-set_soname.patch
+)
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && \
+ use openmp && ! tc-has-openmp ; then
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "s#\"lib\"#\"$(get_libdir)\"#g" \
+ -e "s#\"lib/#\"$(get_libdir)/#g" \
+ cmake/install_helpers.cmake || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DGINKGO_DEVEL_TOOLS=OFF
+ -DGINKGO_BUILD_TESTS=OFF
+ -DGINKGO_BUILD_BENCHMARKS=OFF
+ -DGINKGO_BUILD_REFERENCE=ON
+ -DGINKGO_BUILD_OMP="$(usex openmp)"
+ -DGINKGO_BUILD_CUDA="$(usex cuda)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/ginkgo/ginkgo-9999.ebuild b/sci-libs/ginkgo/ginkgo-9999.ebuild
new file mode 100644
index 000000000000..5348b9a51be6
--- /dev/null
+++ b/sci-libs/ginkgo/ginkgo-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical linear algebra software package"
+HOMEPAGE="https://ginkgo-project.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/ginkgo-project/ginkgo"
+ SRC_URI=""
+ KEYWORDS=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+IUSE="+openmp cuda"
+
+RDEPEND="
+ cuda? ( dev-util/nvidia-cuda-sdk )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-set_soname.patch
+)
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && \
+ use openmp && ! tc-has-openmp ; then
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "s#\"lib\"#\"$(get_libdir)\"#g" \
+ -e "s#\"lib/#\"$(get_libdir)/#g" \
+ cmake/install_helpers.cmake || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DGINKGO_DEVEL_TOOLS=OFF
+ -DGINKGO_BUILD_TESTS=OFF
+ -DGINKGO_BUILD_BENCHMARKS=OFF
+ -DGINKGO_BUILD_REFERENCE=ON
+ -DGINKGO_BUILD_OMP="$(usex openmp)"
+ -DGINKGO_BUILD_CUDA="$(usex cuda)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/ginkgo/metadata.xml b/sci-libs/ginkgo/metadata.xml
new file mode 100644
index 000000000000..2b6a2c10b332
--- /dev/null
+++ b/sci-libs/ginkgo/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ginkgo is a high-performance linear algebra library for manycore
+ systems, with a focus on sparse solution of linear systems. It is
+ implemented using modern C++, with GPU kernels implemented in CUDA.
+ </longdescription>
+ <use>
+ <flag name="cuda">Add support for cuda assimp (<pkg>dev-util/nvidia-cuda-sdk</pkg>)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ginkgo-project/ginkgo</remote-id>
+ </upstream>
+</pkgmetadata>