summaryrefslogtreecommitdiff
path: root/sci-libs/geos/geos-3.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:00:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:00:32 +0100
commitab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (patch)
tree2fa77fd80cb0e85ab3e48e6a0558cd3a52ee04c3 /sci-libs/geos/geos-3.8.0.ebuild
parent5a165c60b9b8c4847067cb83b4be7da785d01f93 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'sci-libs/geos/geos-3.8.0.ebuild')
-rw-r--r--sci-libs/geos/geos-3.8.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.8.0.ebuild b/sci-libs/geos/geos-3.8.0.ebuild
new file mode 100644
index 000000000000..3ad295e1f4be
--- /dev/null
+++ b/sci-libs/geos/geos-3.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+MY_PV=${PV/_/}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+ ruby? ( dev-lang/swig:0 )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${D}" -name '*.la' -delete || die
+}