summaryrefslogtreecommitdiff
path: root/sci-libs/foxi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/foxi
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/foxi')
-rw-r--r--sci-libs/foxi/Manifest4
-rw-r--r--sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch73
-rw-r--r--sci-libs/foxi/foxi-2021.05.27.ebuild28
-rw-r--r--sci-libs/foxi/metadata.xml11
4 files changed, 116 insertions, 0 deletions
diff --git a/sci-libs/foxi/Manifest b/sci-libs/foxi/Manifest
new file mode 100644
index 000000000000..13a9dc7d0725
--- /dev/null
+++ b/sci-libs/foxi/Manifest
@@ -0,0 +1,4 @@
+AUX foxi-2021.05.27-gentoo.patch 2398 BLAKE2B 53ed8efa8c86460768839ef071567632793fadca138d72b5e7f07619db769dbbd2d4497bfb71d63ba47c201b17fb6a415a116ee05f56083c8cbc1a00b147e31a SHA512 4b81687444653d1614226b6696ee6515e652b62746187e0b44dcff1db7bfea653cee4d9e20775d6b8e2aca7430f0f654db3da95e3a784d477373da528b05b39e
+DIST foxi-2021.05.27.tar.gz 28960 BLAKE2B 06c960f829b090eec4fe9e8c981e119578f358724e0b63991173bb7e318d23654261b901d1e15efeb6240bba75cc05fd45ab32fb30bbdf48369e139cf152f398 SHA512 ad42cfd70e40ba0f0a9187b34ae9e3bd361c8c0038669f4c1591c4f7421d12ad93f76f42b33c2575eea1a3ddb3ff781da2895cdc636df5b60422598f450203c7
+EBUILD foxi-2021.05.27.ebuild 545 BLAKE2B 042d2c219e2d64eedec13ec8f08088cb2b974bca10901a75bec3c4cc9f5336a3393887fcb8575007f0d0081678a58c7c7b3c1a60a69f81e0e10b14bb160031d7 SHA512 673a11afbc86b6d9dd01956e391caf26f284a2719a5ce6f2c1489b7b6e9193cceaed00442b2565ae183bdd99a83c342d06e4b9cb7edadf0c1876b4ec0cd3dc34
+MISC metadata.xml 327 BLAKE2B d9b056783fbf66675262cb93b1faf4cd410f1ea34c877480896602f07b1a6e136d7e4168d41725d4b4bd8743155508500e1f9d80b9158acce72bca7a84596953 SHA512 4598a70431dd411d24237ec4b97ec2ab57d9a46fcbcfd3416edfa1623baf7f10599c932ae22d6bd9d69f7898a1e51322ae084ececd2a44c2d73d07cc9817f863
diff --git a/sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch b/sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch
new file mode 100644
index 000000000000..f252ae4fcdb2
--- /dev/null
+++ b/sci-libs/foxi/files/foxi-2021.05.27-gentoo.patch
@@ -0,0 +1,73 @@
+--- a/CMakeLists.txt 2022-06-13 21:42:28.197087591 +0200
++++ b/CMakeLists.txt 2022-06-13 21:44:49.787170054 +0200
+@@ -77,6 +77,7 @@
+ OUTPUT_NAME "foxi"
+ POSITION_INDEPENDENT_CODE YES)
+ target_link_libraries(foxi_wrapper PRIVATE foxi_loader foxi)
++ target_link_options(foxi_wrapper PUBLIC "-Wl,-soname=libfoxi.so")
+ if(DEFINED FOXI_SEARCH_DIR)
+ target_compile_definitions(foxi_wrapper PRIVATE "FOXI_SEARCH_DIR=\"${FOXI_SEARCH_DIR}\"")
+ endif()
+@@ -115,11 +116,11 @@
+
+ install(TARGETS
+ foxi foxi_dummy foxi_loader
+- EXPORT ONNXTargets DESTINATION lib)
++ EXPORT ONNXTargets DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ if(NOT ANDROID AND NOT IOS)
+ install(TARGETS foxi_wrapper
+- EXPORT ONNXTargets DESTINATION lib)
++ EXPORT ONNXTargets DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
+
+ set(FOXI_INCLUDE_DIRS "${FOXI_ROOT}" "${CMAKE_CURRENT_BINARY_DIR}")
+--- a/foxi/onnxifi_wrapper.c 2022-06-14 08:07:07.351585673 +0200
++++ b/foxi/onnxifi_wrapper.c 2022-06-14 08:11:21.680855591 +0200
+@@ -761,7 +761,9 @@
+ const void* onnxModel,
+ uint32_t weightsCount,
+ const onnxTensorDescriptorV1* weightDescriptors,
+- onnxGraph* graph)
++ onnxGraph* graph,
++ uint32_t maxSeqLength,
++ void* deferredWeightReader)
+ {
+ if (graph == NULL) {
+ return ONNXIFI_STATUS_INVALID_POINTER;
+@@ -797,7 +799,9 @@
+ onnxModel,
+ weightsCount,
+ weightDescriptors,
+- &graph_wrapper->graph);
++ &graph_wrapper->graph,
++ maxSeqLength,
++ deferredWeightReader);
+ switch (status) {
+ case ONNXIFI_STATUS_SUCCESS:
+ case ONNXIFI_STATUS_FALLBACK:
+--- a/foxi/onnxifi_dummy.c 2022-06-14 08:14:02.484503254 +0200
++++ b/foxi/onnxifi_dummy.c 2022-06-14 08:17:01.408891030 +0200
+@@ -103,7 +103,9 @@
+ const void* onnxModel,
+ uint32_t weightCount,
+ const onnxTensorDescriptorV1* weightDescriptors,
+- onnxGraph* graph) {
++ onnxGraph* graph,
++ uint32_t maxSeqLength,
++ void* deferredWeightReader) {
+ if (graph == NULL) {
+ return ONNXIFI_STATUS_INVALID_POINTER;
+ }
+@@ -215,6 +217,8 @@
+ onnxWaitEventFor(onnxEvent event,
+ uint32_t timeoutMs,
+ onnxEventState* eventState,
+- onnxStatus* eventStatus) {
++ onnxStatus* eventStatus,
++ char* message,
++ size_t* messageLength) {
+ return ONNXIFI_STATUS_SUCCESS;
+-}
+\ No newline at end of file
++}
diff --git a/sci-libs/foxi/foxi-2021.05.27.ebuild b/sci-libs/foxi/foxi-2021.05.27.ebuild
new file mode 100644
index 000000000000..5a3d59c25fd3
--- /dev/null
+++ b/sci-libs/foxi/foxi-2021.05.27.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+CommitId=c278588e34e535f0bb8f00df3880d26928038cad
+
+DESCRIPTION="ONNXIFI with Facebook Extension"
+HOMEPAGE="https://github.com/houseroad/foxi/"
+SRC_URI="https://github.com/houseroad/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+"
+RESTRICT="test" # No test available
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
diff --git a/sci-libs/foxi/metadata.xml b/sci-libs/foxi/metadata.xml
new file mode 100644
index 000000000000..2b6c8e44882d
--- /dev/null
+++ b/sci-libs/foxi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">houseroad/foxi</remote-id>
+ </upstream>
+</pkgmetadata>