summaryrefslogtreecommitdiff
path: root/sci-libs/fcl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sci-libs/fcl
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sci-libs/fcl')
-rw-r--r--sci-libs/fcl/Manifest6
-rw-r--r--sci-libs/fcl/fcl-0.6.1.ebuild72
-rw-r--r--sci-libs/fcl/fcl-9999.ebuild65
-rw-r--r--sci-libs/fcl/metadata.xml11
4 files changed, 132 insertions, 22 deletions
diff --git a/sci-libs/fcl/Manifest b/sci-libs/fcl/Manifest
index 51386b99007a..95910f6b2a65 100644
--- a/sci-libs/fcl/Manifest
+++ b/sci-libs/fcl/Manifest
@@ -1,4 +1,6 @@
DIST fcl-0.5.0.tar.gz 5760425 BLAKE2B 5eac7ace3801740a6317bcc558199b5791e3e5c4fbd63305e5173597b1ecf647388a92bc894629598f963aacd0dd6f894717ae76b3bf7fc9c62a55d9330caf20 SHA512 8741c664720cb32e368e0139881ce69c29e3ccb9633ddc22f47b89918774dbc19541c68e1dbfd78a91f4c8c226ad4c0e1867b6e62111d4311fe907310fc71794
+DIST fcl-0.6.1.tar.gz 6208928 BLAKE2B 174176b3844b18ada60884f641c49475357b1c25cb58cdfc1c4545d595add58713020ffaf148676dae14eca87397495cc971423f06fd19af5cffac1bde584603 SHA512 9d5382c1f2701f2cc6988b3e3969f44c401ea0eb4fdfc5ae69c27dd5bb59a0f17de82ef49e7dce0e1fd91a133db6f10aef9581ca2e32b919046f72921593ebf4
EBUILD fcl-0.5.0.ebuild 856 BLAKE2B 752403368628d3d33ebaec23ed5be6a78bcce1ce172b757b063667621e5ca77f39bdace4968ec0c09f4b52d34f101d2af8fb02180b72484ae86cd93125066e2d SHA512 8e0b0f27862a5a1f621fdae61597bb900defb0e3031004692297393ed18d9654409eb0ef5ca4c4d5d51911eee371dce7f58a18d1a84be282662bd07f31d4dc7f
-EBUILD fcl-9999.ebuild 856 BLAKE2B 236ff30837ddb3b614b0e5a1fe149e308e6b4a2b0d08614e38f4598d09291ec1f1baf0d5e182f3b4230a402e48f6fd2c044d2a3e4633854d400168f1972caaa8 SHA512 a2aed79e23a003c247467a64dd3b052a09a0feda3ee5156f759039614a63f455ea1576dc8b750cb77766687ea8c90d7e3674e864e5a4cf8ae531a49146051c74
-MISC metadata.xml 344 BLAKE2B cd9476f3276e24a502e35056fe91c0791192ec1ab431d8e960d94e26865b5247944dedd5cef619e256598864e49366aec3bedf7347e95f78398416a670de9139 SHA512 d5d4ea55ebdabfcd86a1dce36974d9ca2f2746f2f8fec463486c108d58a6cf53850b511bdeef8546d05ecd7fb165d7c13b51eb834d353c25002acc1473c6b5bf
+EBUILD fcl-0.6.1.ebuild 1870 BLAKE2B 357a6f0c345eddedf3430993d830ded7bda6d27383a961db1f06a65dce11b2f2aa68f37ccf0f25fb2ac9b8deec781d47da2c03671e34dbd87bb2276daafa8c45 SHA512 6e2082a7ab5603f0f81d314b056da249b0835a030478e5f8ad39c6bd8a4e3cbab514c0c9f52360a5d1cea3883914971fe6f4e3eecf7a5fe35855e0b891becdf4
+EBUILD fcl-9999.ebuild 1519 BLAKE2B e94b02c6836e8fa55c3131401359079f832e1b12ec388e338b18ddb0b78a2d4ea5a9aca624894b544a7f2ed4256a597c86aba740ee522b31299e1bd115c528d2 SHA512 90d94cc60a95af83c71c68ed2fd544c27499f2dd7fb4a20a91686b54ffa73a20c4f61a7e04520591287c2b8c6c210a5fa5c0ee9a7379095f5d473e494c55a19e
+MISC metadata.xml 769 BLAKE2B 7c7ffe7a13124d5300e220f1fe060f20764221505d2bc07040f5e1e9caef99ba57f46386cae2d5062d8978654052e00981513f8f0f08d5fa5470fe44a5bb155b SHA512 a01195a169fbd286c3f6d6789681d3134676c4e8b7de6332f35a89751167e0132117b6588404803e8f09fd2b61578705357ea389f969a7aae227c887871b8342
diff --git a/sci-libs/fcl/fcl-0.6.1.ebuild b/sci-libs/fcl/fcl-0.6.1.ebuild
new file mode 100644
index 000000000000..8c1a80c0eb37
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+
+LICENSE="BSD"
+SLOT="0/6"
+IUSE="cpu_flags_x86_sse doc +octomap profiling test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost:=[threads]
+ sci-libs/flann
+ sci-libs/libccd[double-precision]
+ octomap? ( sci-libs/octomap )
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # Upstream issue:
+ # https://github.com/flexible-collision-library/fcl/issues/485
+ rm "${S}"/test/narrowphase/detail/convexity_based_algorithm/test_gjk_libccd-inl_gjk_doSimplex2.cpp
+ sed -i -e 's/test_gjk_libccd-inl_gjk_doSimplex2.cpp//' "${S}"/test/narrowphase/detail/convexity_based_algorithm/CMakeLists.txt || die could not disable failing test
+
+ sed -i -e "s/include(CompilerSettings)//" "${S}"/CMakeLists.txt || die "failed to remove compiler flags override"
+
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DFCL_COVERALLS=OFF
+ -DFCL_COVERALLS_UPLOAD=OFF
+ -DFCL_ENABLE_PROFILING=$(usex profiling ON OFF)
+ -DFCL_TREAT_WARNINGS_AS_ERRORS=OFF
+ -DFCL_USE_HOST_NATIVE_ARCH=OFF
+ -DFCL_USE_X64_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DFCL_WITH_OCTOMAP=$(usex octomap ON OFF)
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && HTML_DOCS=( "${S}"/doc/doxygen/html )
+ einstalldocs
+}
diff --git a/sci-libs/fcl/fcl-9999.ebuild b/sci-libs/fcl/fcl-9999.ebuild
index 6d823b172040..fe367b10808f 100644
--- a/sci-libs/fcl/fcl-9999.ebuild
+++ b/sci-libs/fcl/fcl-9999.ebuild
@@ -1,41 +1,66 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
-fi
-
-inherit ${SCM} cmake-utils
+inherit cmake
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
- SRC_URI=""
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/${PN}.git"
+ inherit git-r3
else
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="The Flexible Collision Library"
HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+
LICENSE="BSD"
-SLOT="0"
-IUSE="cpu_flags_x86_sse"
+SLOT="0/6"
+IUSE="cpu_flags_x86_sse doc +octomap profiling test"
+RESTRICT="!test? ( test )"
RDEPEND="
- sci-libs/octomap
- sci-libs/flann
+ dev-cpp/eigen:3
dev-libs/boost:=[threads]
- sci-libs/libccd"
+ sci-libs/flann
+ sci-libs/libccd[double-precision]
+ octomap? ( sci-libs/octomap )"
+
DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ sed -i -e "s/include(CompilerSettings)//" "${S}"/CMakeLists.txt || die "failed to remove compiler flags override"
+
local mycmakeargs=(
- "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DFCL_COVERALLS=OFF
+ -DFCL_COVERALLS_UPLOAD=OFF
+ -DFCL_ENABLE_PROFILING=$(usex profiling ON OFF)
+ -DFCL_TREAT_WARNINGS_AS_ERRORS=OFF
+ -DFCL_USE_HOST_NATIVE_ARCH=OFF
+ -DFCL_USE_X64_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DFCL_WITH_OCTOMAP=$(usex octomap ON OFF)
)
- cmake-utils_src_configure
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && HTML_DOCS=( "${S}"/doc/doxygen/html )
+ einstalldocs
}
diff --git a/sci-libs/fcl/metadata.xml b/sci-libs/fcl/metadata.xml
index fbedec0d5c16..35079633a42a 100644
--- a/sci-libs/fcl/metadata.xml
+++ b/sci-libs/fcl/metadata.xml
@@ -5,7 +5,18 @@
<email>aballier@gentoo.org</email>
<name>Alexis Ballier</name>
</maintainer>
+ <longdescription>
+ FCL is a library for performing three types of proximity queries on a pair of geometric models composed of triangles.
+ </longdescription>
+ <use>
+ <flag name="octomap">OctoMap library support</flag>
+ <flag name="profiling">Enable profiling</flag>
+ </use>
+ <slots>
+ <subslots>Soname version number of fcl</subslots>
+ </slots>
<upstream>
+ <bugs-to>https://github.com/lexible-collision-library/fcl/issues</bugs-to>
<remote-id type="github">flexible-collision-library/fcl</remote-id>
</upstream>
</pkgmetadata>