summaryrefslogtreecommitdiff
path: root/sci-libs/dlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/dlib
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/dlib')
-rw-r--r--sci-libs/dlib/Manifest5
-rw-r--r--sci-libs/dlib/dlib-19.4.ebuild71
-rw-r--r--sci-libs/dlib/metadata.xml22
3 files changed, 98 insertions, 0 deletions
diff --git a/sci-libs/dlib/Manifest b/sci-libs/dlib/Manifest
new file mode 100644
index 000000000000..04c2120c7b2d
--- /dev/null
+++ b/sci-libs/dlib/Manifest
@@ -0,0 +1,5 @@
+DIST dlib-19.4.tar.gz 7226923 SHA256 2bed9669f1a5c436579498d0806b27a9b60c42a975a9b6e67b594b40f58b1a88 SHA512 23bf80353f9b6ce07b6a3a7df05016705645c18bcf2b3ead567935008ea12c9f6dc0722d9bbacc009bd26f78eb43c1cbecf776bfed5a3445c1f2e8e208f201e2 WHIRLPOOL 300670d12b306e224fce6d7f22d79690f543876f78d30064ab2f9782a3a79a031a6b048863a5a2b21f27eb2538b9ab42f9d00dc88f144129fa591b4b1387c367
+EBUILD dlib-19.4.ebuild 1797 SHA256 8b3d3603e881faa1c1d621a3c4d0386d067a0f3a486ce1bc85f0917fc3bcede1 SHA512 ef2172c18b446cf98c79e9b6a4dcf622ca62d05cc353d82d35385a16a334a94d5689af5117f9fee26e9e32346da57227beb83ca35b4b216135ad15b214042328 WHIRLPOOL 2dd5b83b0d721525b230eda84316138724082e772d46e26865165d7b6381c9f9630f616cf6a0ece4417a2d4e8880b400d1936aafa85b24be6a75cf6b75190157
+MISC ChangeLog 2501 SHA256 4b1b8653163e2bfa42bbb9c0c28440f33e8e3b4b9dcfed1e62878791348f5258 SHA512 8af6e77f9b18720fea7d5acdad3e8016f5ecd57be420bb7b0a037313ac040a2271daad1a86826a8d6bf284d1d7a489048d8caacc3ed8d1b8a9fb927979ae81a1 WHIRLPOOL 2b0bfd82c5265319d778f0e6df76b97e28a55f033e10942c0be8ebafe308c76f3e4edc7009caeae6cfc9da6def8b002fba36eee3052463fa03a2da79520fdc8c
+MISC ChangeLog-2015 1702 SHA256 47ca3c6e624813797d3a4c616e0c05773007de7e7197360f5786420e0cdd7572 SHA512 341bf52c70e19948f7ae992d2ec6b15dca4eb0362dd0ddf07370e90506112bc688bf0845856ecc6c047d4509039131bcbed720552a2996085b30d5ad62af8f45 WHIRLPOOL e8a47afcb071c3c3b763b75bcf288469cf20873759e4da8fdeddd0d79f86f292b090d5d1b3feec23b21540c8a59aebe488e8757ed123e01bd61a2b238fb87605
+MISC metadata.xml 932 SHA256 0918e11904ec20ee27b01f963a5eac4279d321b683f03f31987502adf1155c3b SHA512 38d0f5760d78564c96dd27209468513c89ae9fd87d517dea16f87d4cd110ce25239b6baf07e58f66d871a2a794545e74f9841569bb2ff2b57782722b026a658a WHIRLPOOL a8c6dbae39283ad9c07f397093af2612cc6e442fdf5655ce0737009c38a4324f0c59d6bc2638cce6bf27a752628e77273f716b3a6a56002bb4edeff36bafa16c
diff --git a/sci-libs/dlib/dlib-19.4.ebuild b/sci-libs/dlib/dlib-19.4.ebuild
new file mode 100644
index 000000000000..c6116343a93b
--- /dev/null
+++ b/sci-libs/dlib/dlib-19.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils cuda
+
+DESCRIPTION="Numerical and networking C++ library"
+HOMEPAGE="http://dlib.net/"
+SRC_URI="https://github.com/davisking/dlib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cblas debug cuda examples gif jpeg lapack mkl png
+ sqlite static-libs test X"
+
+# doc needs a bunch of deps not in portage
+
+RDEPEND="
+ cblas? ( virtual/cblas:= )
+ cuda? ( dev-libs/cudnn:= )
+ jpeg? ( virtual/jpeg:0= )
+ lapack? ( virtual/lapack:= )
+ mkl? ( sci-libs/mkl:= )
+ png? ( media-libs/libpng:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ X? ( x11-libs/libX11:= )
+"
+DEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ cmake-utils_src_prepare
+ sed -i -e '/LICENSE.txt/d' dlib/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DDLIB_ENABLE_ASSERTS="$(usex debug)"
+ -DDLIB_ENABLE_STACK_TRACE="$(usex debug)"
+ -DDLIB_GIF_SUPPORT="$(usex gif)"
+ -DDLIB_JPEG_SUPPORT="$(usex jpeg)"
+ -DDLIB_PNG_SUPPORT="$(usex png)"
+ -DDLIB_LINK_WITH_SQLITE3="$(usex sqlite)"
+ -DDLIB_NO_GUI_SUPPORT="$(usex X OFF ON)"
+ -DDLIB_USE_BLAS="$(usex cblas)"
+ -DDLIB_USE_CUDA="$(usex cuda)"
+ -DDLIB_USE_LAPACK="$(usex lapack)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ mkdir "${BUILD_DIR}"/dlib/test || die
+ pushd "${BUILD_DIR}"/dlib/test > /dev/null || die
+ cmake "${S}"/dlib/test && emake
+ ./dtest --runall || die
+ popd > /dev/null || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc docs/README.txt
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}
diff --git a/sci-libs/dlib/metadata.xml b/sci-libs/dlib/metadata.xml
new file mode 100644
index 000000000000..422f29c52e5a
--- /dev/null
+++ b/sci-libs/dlib/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ dlib is a C++ library for developing portable applications dealing with
+ networking, threads, graphical interfaces, data structures, linear
+ algebra, machine learning, XML and text parsing, numerical
+ optimization, Bayesian nets, and numerous other tasks.
+ </longdescription>
+ <use>
+ <flag name="cblas">Build with CBLAS <pkg>virtual/cblas</pkg></flag>
+ <flag name="cuda">Enable support for CUDA for Deep Neural Networks (cuDNN) on GPU (experimental)</flag>
+ <flag name="mkl">Enable support for Intel FFT <pkg>sci-libs/mkl</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">davisking/dlib</remote-id>
+ </upstream>
+</pkgmetadata>